package/gst1-plugins-good: add option for qmlgl plugin (qt5 plugin)
authorIñigo Huguet <inigohuguet@fanamoel.com>
Tue, 18 Sep 2018 10:58:27 +0000 (12:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 7 Apr 2019 13:23:51 +0000 (15:23 +0200)
gst1-plugins-good is built with --disable-qt option, so qmlgl plugin
is disabled. Add an option to enable it, allowing to use the qmlglsrc
and qmlglsink GStreamer elements.

Signed-off-by: Iñigo Huguet <inigohuguet@fanamoel.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-good/Config.in
package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk

index afb9a418d892218e638c2d4f089a05fce67f9c37..30a4876ee7843b989e10b7344afb6d773ea3ca85 100644 (file)
@@ -283,6 +283,23 @@ config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_OSS4
        help
          Open Sound System (OSS) version 4 support for GStreamer
 
+config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_QMLGL
+       bool "qmlgl (qt5)"
+       depends on BR2_PACKAGE_QT5
+       depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE # qt5declarative
+       depends on BR2_PACKAGE_QT5_GL_AVAILABLE || BR2_PACKAGE_QT5_VERSION_LATEST # qt5declarative-quick
+       select BR2_PACKAGE_QT5BASE_WIDGETS
+       select BR2_PACKAGE_QT5DECLARATIVE
+       select BR2_PACKAGE_QT5DECLARATIVE_QUICK
+       select BR2_PACKAGE_QT5X11EXTRAS if BR2_PACKAGE_QT5BASE_XCB
+       help
+         QT5 plugin which includes elements qmlglsrc and qmlglsink
+
+comment "qmlgl (qt5) plugin needs an OpenGL-capable Qt5 backend"
+       depends on BR2_PACKAGE_QT5
+       depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
+       depends on !BR2_PACKAGE_QT5_GL_AVAILABLE && !BR2_PACKAGE_QT5_VERSION_LATEST
+
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2
        bool "v4l2"
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # multi planar api
index 2e6ac6dbb30b9f041c2bda8131f559f83862821d..f6a3037be0a6629e978e1aff1df4e7b96d4fb901 100644 (file)
@@ -20,8 +20,7 @@ GST1_PLUGINS_GOOD_CONF_OPTS = \
        --disable-osx_video \
        --disable-aalib \
        --disable-aalibtest \
-       --disable-libcaca \
-       --disable-qt
+       --disable-libcaca
 
 # Options which require currently unpackaged libraries
 GST1_PLUGINS_GOOD_CONF_OPTS += \
@@ -334,6 +333,16 @@ else
 GST1_PLUGINS_GOOD_CONF_OPTS += --disable-oss4
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_QMLGL),y)
+GST1_PLUGINS_GOOD_CONF_OPTS += --enable-qt
+GST1_PLUGINS_GOOD_DEPENDENCIES += qt5declarative
+ifeq ($(BR2_PACKAGE_QT5BASE_XCB),y)
+GST1_PLUGINS_GOOD_DEPENDENCIES += qt5x11extras
+endif
+else
+GST1_PLUGINS_GOOD_CONF_OPTS += --disable-qt
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2),y)
 GST1_PLUGINS_GOOD_CONF_OPTS += --enable-gst_v4l2
 else