jimtcl: fix sparc64 compile
authorWaldemar Brodkorb <wbx@openadk.org>
Mon, 23 Nov 2015 16:48:53 +0000 (17:48 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 26 Nov 2015 21:33:18 +0000 (22:33 +0100)
It is general safe to use -fPIC for all architectures.
-fpic breaks sparc64 compile.

Generally gcc just optimize position independent code
for m68k, powerpc and sparc with -fpic.
The size differences are minimal, f.e. for powerpc:
   text    data     bss     dec     hex filename
 235983    5336     684  242003   3b153 output/target/usr/lib/libjim.0.75
 236255    8456     684  245395   3be93 output/target/usr/lib/libjim.so.0.75

So instead of keeping special settings for sparc64 it would be better
to always use -fPIC in general.

Runtime tested on Qemu ARM, MIPS, PPC and SPARC64.
Fixes:
http://autobuild.buildroot.net/results/98f391ad13f22828c022f185c0166daabdb4c1ad/

[Peter: tweak comment as suggested by Thomas]
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jimtcl/jimtcl.mk

index 4afb217a4d4319d154aca3ef819c81766fc00240..fe35223b43eda18269f115486b2fda3d417b3c33 100644 (file)
@@ -46,7 +46,11 @@ define JIMTCL_CONFIGURE_CMDS
        )
 endef
 
+# -fPIC is mandatory to build shared libraries on certain architectures
+# (e.g. SPARC) and causes no harm or drawbacks on other architectures
 define JIMTCL_BUILD_CMDS
+       SH_CFLAGS="-fPIC" \
+       SHOBJ_CFLAGS="-fPIC" \
        $(MAKE) -C $(@D)
 endef