xbmc: fix missing libraries from rpi-userland
authorSamuel Martin <s.martin49@gmail.com>
Wed, 4 Jun 2014 23:04:11 +0000 (01:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Jun 2014 13:10:22 +0000 (15:10 +0200)
When rpi-userland libraries are built as shared-objects, not all needed
libraries are passed in the LD_FLAGS, leading to failure at linkage.

To avoid this issue, set the LIBS variable content in accordance with the
INCLUDES variable value.

The commit 5e3b1f31b3f82e3b163567f10d7131c9d649a2cf currently works
around this issue by forcing rpi-userland to be statically linked,
whereas it is actually a LIBS flags problem in xbmc package.

A follow-up patch fixes rpi-userland package.

Reported-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: "Maxime Hadjinlian" <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xbmc/xbmc.mk

index ca605a4c804693ee1e632c36ec1aadf5a221d8c5..1d458d4e78dd01a5d79cfd5f7f194b1df599c93f 100644 (file)
@@ -65,7 +65,8 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 XBMC_DEPENDENCIES += rpi-userland
 XBMC_CONF_OPT += --with-platform=raspberry-pi --enable-player=omxplayer
 XBMC_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
-       -I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux"
+       -I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux" \
+       LIBS="-lvcos -lvchostif"
 endif
 
 ifeq ($(BR2_PACKAGE_DBUS),y)