arm-trusted-firmware: bump to version 1.4
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 12 Oct 2017 19:54:16 +0000 (21:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 12 Oct 2017 20:03:47 +0000 (22:03 +0200)
The license file got reformatted as reStructuredText, but the license itself
didn't change.

Drop unneeded md5sum and add license hash.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/arm-trusted-firmware/Config.in
boot/arm-trusted-firmware/arm-trusted-firmware.hash
boot/arm-trusted-firmware/arm-trusted-firmware.mk

index 2df82678643491ea10bd01559fd2d5c439225e07..799370cd512bdbd20efd61447a4100493c5592ea 100644 (file)
@@ -14,7 +14,7 @@ choice
          Select the specific ATF version you want to use
 
 config BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_VERSION
-       bool "v1.2"
+       bool "v1.4"
 
 config BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL
        bool "Custom tarball"
@@ -33,7 +33,7 @@ endif
 
 config BR2_TARGET_ARM_TRUSTED_FIRMWARE_VERSION
        string
-       default "v1.2"          if BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_VERSION
+       default "v1.4"          if BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_VERSION
        default "custom"        if BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL
        default BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_REPO_VERSION \
                                if BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_GIT
index e048e0127a955567f260e43b38a25d9e8f00d151..394071865ecbc4555972a34015318a08fd28b7a4 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 cbdd9b770ec1ab4933fc7f9f520daea5a364bb4dc964820fb017a0cf8c7df556 arm-trusted-firmware-v1.2.tar.gz
-md5 fac2c08bd74337fec2e14a98fc9f748f arm-trusted-firmware-v1.2.tar.gz
+sha256 6dae02acd85278394bfad6e2683e186e5332a711e4491ac4632ad6480f6e5494 arm-trusted-firmware-v1.4.tar.gz
+sha256 487795b8023df866259fa159bab94706b747fb0d623b7913f1c4955c0ab5f164  license.rst
index e02c62262f158addcfdc3356898367dfee609d56..7b1cc6ebb6711babd2f8c01a67363c1978b0725e 100644 (file)
@@ -6,7 +6,7 @@
 
 ARM_TRUSTED_FIRMWARE_VERSION = $(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_VERSION))
 ARM_TRUSTED_FIRMWARE_LICENSE = BSD-3-Clause
-ARM_TRUSTED_FIRMWARE_LICENSE_FILES = license.md
+ARM_TRUSTED_FIRMWARE_LICENSE_FILES = license.rst
 
 ARM_TRUSTED_FIRMWARE_DEPENDENCIES += uboot