package/datatables-responsive: new package
authorJoeri Barbarien <joeri.barbarien@nokia.com>
Tue, 8 Dec 2020 18:05:28 +0000 (19:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 2 Jan 2021 11:24:12 +0000 (12:24 +0100)
Signed-off-by: Joeri Barbarien <joeri.barbarien@nokia.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/datatables-responsive/Config.in [new file with mode: 0644]
package/datatables-responsive/datatables-responsive.hash [new file with mode: 0644]
package/datatables-responsive/datatables-responsive.mk [new file with mode: 0644]

index 1095588f4648ee612f5d3b0a1383f8e176bf0d17..6a0c2ed7b9174bc33063d73e1f1af7077db272e8 100644 (file)
@@ -2518,6 +2518,7 @@ F:        package/chartjs/
 F:     package/datatables/
 F:     package/datatables-buttons/
 F:     package/datatables-fixedcolumns/
+F:     package/datatables-responsive/
 F:     package/jszip/
 F:     package/libtelnet/
 F:     package/opkg-utils/
index f1e8b6f20e34ac24274715f69fc96f373c1d3d0d..6451ad4b4742245195bd758c7c406582f5855778 100644 (file)
@@ -1582,6 +1582,7 @@ endif
        source "package/datatables/Config.in"
        source "package/datatables-buttons/Config.in"
        source "package/datatables-fixedcolumns/Config.in"
+       source "package/datatables-responsive/Config.in"
        source "package/duktape/Config.in"
        source "package/explorercanvas/Config.in"
        source "package/flot/Config.in"
diff --git a/package/datatables-responsive/Config.in b/package/datatables-responsive/Config.in
new file mode 100644 (file)
index 0000000..085824a
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_DATATABLES_RESPONSIVE
+       bool "datatables-responsive"
+       depends on BR2_PACKAGE_DATATABLES
+       help
+         In the modern world of responsive web design tables can often
+         cause a particular problem for designers due to their row
+         based layout.  Responsive is an extension for DataTables that
+         resolves that problem by optimising the table's layout for
+         different screen sizes through the dynamic insertion and
+         removal of columns from the table.
+
+         https://datatables.net/extensions/responsive
diff --git a/package/datatables-responsive/datatables-responsive.hash b/package/datatables-responsive/datatables-responsive.hash
new file mode 100644 (file)
index 0000000..d10313f
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed:
+sha256 47caf3b753dd2c537b8834816eaf38c4df214cb4e6a97144e0de4cf82ad24d02  Responsive-2.2.3.zip
+sha256 da4e1020ae97c095a14d7830c1a8a793e080c062e22d749ecd3fc3c075673dbf  License.txt
diff --git a/package/datatables-responsive/datatables-responsive.mk b/package/datatables-responsive/datatables-responsive.mk
new file mode 100644 (file)
index 0000000..bc96447
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# datatables-responsive
+#
+################################################################################
+
+DATATABLES_RESPONSIVE_VERSION = 2.2.3
+DATATABLES_RESPONSIVE_SITE = https://datatables.net/releases
+DATATABLES_RESPONSIVE_SOURCE =  Responsive-$(DATATABLES_RESPONSIVE_VERSION).zip
+DATATABLES_RESPONSIVE_LICENSE = MIT
+DATATABLES_RESPONSIVE_LICENSE_FILES = License.txt
+
+define DATATABLES_RESPONSIVE_EXTRACT_CMDS
+       $(UNZIP) $(DATATABLES_RESPONSIVE_DL_DIR)/$(DATATABLES_RESPONSIVE_SOURCE) -d $(@D)
+       mv $(@D)/Responsive-$(DATATABLES_RESPONSIVE_VERSION)/* $(@D)
+       rmdir $(@D)/Responsive-$(DATATABLES_RESPONSIVE_VERSION)
+endef
+
+define DATATABLES_RESPONSIVE_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -d $(TARGET_DIR)/var/www/datatables-responsive/css $(TARGET_DIR)/var/www/datatables-responsive/js
+       $(INSTALL) -m 0644 -t $(TARGET_DIR)/var/www/datatables-responsive/css $(@D)/css/*.min.css
+       $(INSTALL) -m 0644 -t $(TARGET_DIR)/var/www/datatables-responsive/js $(@D)/js/*.min.js
+endef
+
+$(eval $(generic-package))