package/duma: add missing define when installing
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 Nov 2014 14:04:33 +0000 (15:04 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 16 Nov 2014 21:48:15 +0000 (22:48 +0100)
Commit 3ab9774 (package/duma: do not let Makefile guess OS) added a
define to not let duma's build system guess the OS, mostly to avoid a
warning, but forgot to add that same define to the install commands.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/duma/duma.mk

index 6e730f9766b311c94b050c08cb080be3e04aae65..5e862ab25ecbbd27c5f82d0b67ef31bf4dc7f522 100644 (file)
@@ -25,11 +25,11 @@ define DUMA_BUILD_CMDS
 endef
 
 define DUMA_INSTALL_STAGING_CMDS
-       $(MAKE) prefix=$(STAGING_DIR)/usr install -C $(@D)
+       $(MAKE) OS=linux prefix=$(STAGING_DIR)/usr install -C $(@D)
 endef
 
 define DUMA_INSTALL_TARGET_CMDS
-       $(MAKE) prefix=$(TARGET_DIR)/usr install -C $(@D)
+       $(MAKE) OS=linux prefix=$(TARGET_DIR)/usr install -C $(@D)
 endef
 
 $(eval $(generic-package))