infozip: fix $(AS) behavior
authorRomain Naour <romain.naour@openwide.fr>
Thu, 30 Jan 2014 22:14:58 +0000 (23:14 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 2 Feb 2014 09:24:37 +0000 (10:24 +0100)
infozip's Makefile expect $(AS) to output by default to <basename>.o
but when called from Buildroot, the value for $(AS) is set
to to invoke the toolchain's $(AS) directly, and the output of it
goes to a.out.

So, define $(AS) with $(CC -c)

Reported-by: Кирилл Луценко <lucenko_kirill@mail.ru>
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/infozip/infozip.mk

index d73edd40c5a4dbf6fefd0585a92c71b603ea53f2..cc2bd34eac75264ff3049bd92c372c36595dc15f 100644 (file)
@@ -11,7 +11,7 @@ INFOZIP_LICENSE = Info-ZIP
 INFOZIP_LICENSE_FILES = LICENSE
 
 define INFOZIP_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) -f unix/Makefile generic
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) AS="$(TARGET_CC) -c" -f unix/Makefile generic
 endef
 
 define INFOZIP_INSTALL_TARGET_CMDS