tpm2-abrmd: bump to version 2.0.3
authorCarlos Santos <casantos@datacom.com.br>
Fri, 16 Nov 2018 02:52:16 +0000 (00:52 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 16 Nov 2018 19:20:35 +0000 (20:20 +0100)
- Drop C++ requirement, which came from tpm2-tss.
- Drom musl restriction.
- Update daemon command-line options in init script.

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tpm2-abrmd/Config.in
package/tpm2-abrmd/S80tpm2-abrmd
package/tpm2-abrmd/tpm2-abrmd.hash
package/tpm2-abrmd/tpm2-abrmd.mk

index 0cac754b3c72d20d65b03bbff7462cbdc69f798b..31c5ae7d6bf0d8494d9b3c0f82c732b9f41d8b3b 100644 (file)
@@ -1,10 +1,8 @@
 config BR2_PACKAGE_TPM2_ABRMD
        bool "tpm2-abrmd"
-       depends on BR2_INSTALL_LIBSTDCPP # tpm2-tss
        depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, libglib2
        depends on BR2_USE_MMU # dbus, libglib2
-       depends on !BR2_TOOLCHAIN_USES_MUSL # TEMP_FAILURE_RETRY(), etc
        select BR2_PACKAGE_DBUS
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_TPM2_TSS
@@ -22,7 +20,6 @@ config BR2_PACKAGE_TPM2_ABRMD
 
          https://github.com/tpm2-software/tpm2-abrmd
 
-comment "tpm2-abrmd needs a uClibc or glibc toolchain w/ C++, wchar, threads"
+comment "tpm2-abrmd needs a toolchain w/ wchar, threads"
        depends on BR2_USE_MMU
-       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR \
-               || !BR2_TOOLCHAIN_HAS_THREADS || BR2_TOOLCHAIN_USES_MUSL
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
index d54c220c04307c1b9c8569f3ed1739b4d0ca9c4d..cfa9d44771c5562a4cf9249890320459e03b259a 100755 (executable)
@@ -49,7 +49,7 @@ stop() {
 check_required_files /etc/dbus-1/system.d/tpm2-abrmd.conf
 
 # defaults
-DAEMON_OPTS="--tcti=device --logger=syslog --max-connections=20 --max-transient-objects=20 --fail-on-loaded-trans"
+DAEMON_OPTS="--tcti=device --logger=syslog --max-connections=20"
 
 # Read configuration variable file if it is present
 [ -r /etc/default/tpm2-abrmd ] && . /etc/default/tpm2-abrmd
index 6af991d4696c0c3c2846f0be84679c6512570989..61a75c0d1be086cf3eb8e2d9285ab70739e2df7a 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256 e32e19de93b539374a485d9df7fe9415ce147ec03c8d9ba6593e50f7a67a7a51  tpm2-abrmd-1.3.0.tar.gz
+sha256 ff0ed283b0300cd784d6bf2b042e167020f8443602974e53b924e9fd98a4b515  tpm2-abrmd-2.0.3.tar.gz
 sha256 18c1bf4b1ba1fb2c4ffa7398c234d83c0d55475298e470ae1e5e3a8a8bd2e448  LICENSE
index b918ceaa4b500438c6ae34688117e41c8df57344..a4d9cfb3843e4ac2154d4995de0981b6437eed3d 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TPM2_ABRMD_VERSION = 1.3.0
+TPM2_ABRMD_VERSION = 2.0.3
 TPM2_ABRMD_SITE = https://github.com/tpm2-software/tpm2-abrmd/releases/download/$(TPM2_ABRMD_VERSION)
 TPM2_ABRMD_LICENSE = BSD-2-Clause
 TPM2_ABRMD_LICENSE_FILES = LICENSE