package/fatcat: new host package
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 21 May 2019 20:40:14 +0000 (22:40 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 23 May 2019 09:10:16 +0000 (11:10 +0200)
Utility to manipulate FAT file systems, E.G. to tweak the output of
genimage.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in.host
package/fatcat/Config.in.host [new file with mode: 0644]
package/fatcat/fatcat.hash [new file with mode: 0644]
package/fatcat/fatcat.mk [new file with mode: 0644]

index d5a7b7d390b2bc3c761f103b8f51bad00d9fb8b9..66dc2504ffa3d48972e9bf2406794caba0b2913e 100644 (file)
@@ -1751,6 +1751,7 @@ F:        configs/sheevaplug_defconfig
 F:     package/bats-core/
 F:     package/docker-compose/
 F:     package/dump1090/
+F:     package/fatcat/
 F:     package/flickcurl/
 F:     package/fscryptctl/
 F:     package/ifmetric/
index bc7e71882b426756d0ff028a845e5c15641cfdf1..d1c6d0d81f4f26b54699509de03dd041a4e506f9 100644 (file)
@@ -18,6 +18,7 @@ menu "Host utilities"
        source "package/e2tools/Config.in.host"
        source "package/f2fs-tools/Config.in.host"
        source "package/faketime/Config.in.host"
+       source "package/fatcat/Config.in.host"
        source "package/fwup/Config.in.host"
        source "package/genext2fs/Config.in.host"
        source "package/genimage/Config.in.host"
diff --git a/package/fatcat/Config.in.host b/package/fatcat/Config.in.host
new file mode 100644 (file)
index 0000000..2c5f669
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_HOST_FATCAT
+       bool "host fatcat"
+       help
+         Fatcat is designed to manipulate FAT filesystems, in order
+         to explore, extract, repair, recover and forensic them. It
+         currently supports FAT12, FAT16 and FAT32.
+
+         https://github.com/Gregwar/fatcat
diff --git a/package/fatcat/fatcat.hash b/package/fatcat/fatcat.hash
new file mode 100644 (file)
index 0000000..a5a6f67
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed:
+sha256 d44f6bb80d20ed50095ace9e71df8da98037db9f22cda76bdd9724d37df69130  fatcat-1.0.6.tar.gz
+sha256 3ea03755e32cf7f5b12981de92a0fdad396448195fe0024990c9cbc388e9866c  LICENSE
diff --git a/package/fatcat/fatcat.mk b/package/fatcat/fatcat.mk
new file mode 100644 (file)
index 0000000..e4f8d75
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# fatcat
+#
+################################################################################
+
+FATCAT_VERSION = 1.0.6
+FATCAT_SITE = $(call github,Gregwar,fatcat,$(FATCAT_VERSION))
+FATCAT_LICENSE = MIT
+FATCAT_LICENSE_FILES = LICENSE
+
+$(eval $(host-cmake-package))