package/perf: fix build failures with high 'make -j' values
authorSteven Noonan <steven@uplinklabs.net>
Thu, 19 Mar 2015 07:19:25 +0000 (00:19 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 19 Mar 2015 12:36:31 +0000 (13:36 +0100)
The 'perf' Makefile is flaky on some kernel versions. It will still parallelize
the build even with 'make -j1' because it explicitly invokes a sub-make with
the correct flags. But the top-level make is not smart enough to handle large
'-j' values.

Signed-off-by: Steven Noonan <steven@uplinklabs.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perf/perf.mk

index 1fcc25863ffad6a685ba80f80c9cfc6bc2bb0ed8..bbdcc5abffc3c765a865256728c7564e5a98b41e 100644 (file)
@@ -53,14 +53,14 @@ define PERF_BUILD_CMDS
                        fi \
                fi \
        fi
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/perf \
+       $(TARGET_MAKE_ENV) $(MAKE1) -C $(LINUX_DIR)/tools/perf \
                $(PERF_MAKE_FLAGS) O=$(@D)
 endef
 
 # After installation, we remove the Perl and Python scripts from the
 # target.
 define PERF_INSTALL_TARGET_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/perf \
+       $(TARGET_MAKE_ENV) $(MAKE1) -C $(LINUX_DIR)/tools/perf \
                $(PERF_MAKE_FLAGS) O=$(@D) install
        $(RM) -rf $(TARGET_DIR)/usr/libexec/perf-core/scripts/
 endef