package/racehound: bump and fix dependencies
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 13 Apr 2016 20:24:37 +0000 (22:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 13 Apr 2016 20:34:40 +0000 (22:34 +0200)
As pointed out by Arnout, racehound does not require kernel headers
3.14-or-later. So, drop this depenency.

It stills require a kernel >= 3.14 to build and run, but we really
have no way to express that dependency as Kconfig options.

Besides, racehound does not build with kernel 4.5 because the struct
modules has been updated. Bump racehound to fix that build failure.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/racehound/Config.in
package/racehound/racehound.mk

index 53e39a8c64dfcd15a570b8849253303aef7a6e31..6f62f81c55fc0d5220d1dd8c80a6a0d4bfbc61d9 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_RACEHOUND
        bool "racehound"
        depends on BR2_LINUX_KERNEL
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR # elfutils
        depends on !BR2_STATIC_LIBS # elfutils
@@ -30,8 +29,7 @@ comment "racehound needs an Linux kernel >= 3.14 to be built"
        depends on !BR2_LINUX_KERNEL
        depends on BR2_i386 || BR2_x86_64
 
-comment "racehound needs a uClibc or (e)glibc toolchain w/ C++, wchar, dynamic library, headers >= 3.14"
+comment "racehound needs a uClibc or (e)glibc toolchain w/ C++, wchar, dynamic library"
        depends on BR2_i386 || BR2_x86_64
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || BR2_STATIC_LIBS \
-               || !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC) \
-               || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14
+               || !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
index 7d8d1e3542e4cee8b40f1241a680fefee9de7563..8e282c1e9b86a4783ebcdf4c646932abdb2b1f8b 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-RACEHOUND_VERSION = f3375911019607a0cb6a15bf68fa62dadd6b790b
+RACEHOUND_VERSION = f09f06fcc3c77c8c5541be3ba5be80aa8148ce0c
 RACEHOUND_SITE = $(call github,winnukem,racehound,$(RACEHOUND_VERSION))
 RACEHOUND_LICENSE = GPLv2
 RACEHOUND_LICENSE_FILES = LICENSE