cosmo: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:46 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 14:41:52 +0000 (15:41 +0100)
[Thomas: indicate that the lpeg dependency is a run-time dependency,
as suggested by Arnout.]

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/cosmo/Config.in [new file with mode: 0644]
package/cosmo/cosmo.mk [new file with mode: 0644]

index 705ff5ac9d6fe61a9ce1eb4cf9e41168b24aeb86..eb39b941aadfc4238d2c1c67e54595553db18811 100644 (file)
@@ -370,6 +370,7 @@ if BR2_PACKAGE_HAS_LUA_INTERPRETER && !BR2_PREFER_STATIC_LIB
 menu "Lua libraries/modules"
 source "package/cgilua/Config.in"
 source "package/copas/Config.in"
+source "package/cosmo/Config.in"
 source "package/coxpcall/Config.in"
 source "package/lbase64/Config.in"
 source "package/ljsyscall/Config.in"
diff --git a/package/cosmo/Config.in b/package/cosmo/Config.in
new file mode 100644 (file)
index 0000000..cf5e123
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_COSMO
+       bool "cosmo"
+       # run-time dependency
+       select BR2_PACKAGE_LPEG
+       help
+         Cosmo is a "safe templates" engine for Lua.
+
+         http://mascarenhas.github.io/cosmo/
diff --git a/package/cosmo/cosmo.mk b/package/cosmo/cosmo.mk
new file mode 100644 (file)
index 0000000..2592f62
--- /dev/null
@@ -0,0 +1,10 @@
+################################################################################
+#
+# cosmo
+#
+################################################################################
+
+COSMO_VERSION = 13.01.30-1
+COSMO_LICENSE = MIT
+
+$(eval $(luarocks-package))