perl-apache-logformat-compiler: new package
authorFrancois Perrad <fperrad@gmail.com>
Sat, 6 Oct 2018 16:55:18 +0000 (18:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 8 Oct 2018 10:21:14 +0000 (12:21 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/perl-apache-logformat-compiler/Config.in [new file with mode: 0644]
package/perl-apache-logformat-compiler/perl-apache-logformat-compiler.hash [new file with mode: 0644]
package/perl-apache-logformat-compiler/perl-apache-logformat-compiler.mk [new file with mode: 0644]

index b667548f666f1ff45113d96b928729e1843dcf29..d68ecaef3fbb4401bd1058e2d225e42df5c51aa8 100644 (file)
@@ -665,6 +665,7 @@ endif
        source "package/perl/Config.in"
 if BR2_PACKAGE_PERL
 menu "Perl libraries/modules"
+       source "package/perl-apache-logformat-compiler/Config.in"
        source "package/perl-appconfig/Config.in"
        source "package/perl-astro-suntime/Config.in"
        source "package/perl-class-inspector/Config.in"
diff --git a/package/perl-apache-logformat-compiler/Config.in b/package/perl-apache-logformat-compiler/Config.in
new file mode 100644 (file)
index 0000000..81d6210
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PERL_APACHE_LOGFORMAT_COMPILER
+       bool "perl-apache-logformat-compiler"
+       select BR2_PACKAGE_PERL_POSIX_STRFTIME_COMPILER
+       help
+         Compile a log format string to perl-code
+
+         https://github.com/kazeburo/Apache-LogFormat-Compiler
diff --git a/package/perl-apache-logformat-compiler/perl-apache-logformat-compiler.hash b/package/perl-apache-logformat-compiler/perl-apache-logformat-compiler.hash
new file mode 100644 (file)
index 0000000..5466435
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    cbb0bf041ade8a39f65eadbdf8a346c1 Apache-LogFormat-Compiler-0.35.tar.gz
+sha256 1654c0000a042a8af052616e30b91c1f0b95a720c8048b59168a8bd99b07271a Apache-LogFormat-Compiler-0.35.tar.gz
+
+# computed by scancpan
+sha256 ab941cfc4794afa2113795b167177d1b25cbc77ebadd016e5727effc2cadd96b LICENSE
diff --git a/package/perl-apache-logformat-compiler/perl-apache-logformat-compiler.mk b/package/perl-apache-logformat-compiler/perl-apache-logformat-compiler.mk
new file mode 100644 (file)
index 0000000..156a0aa
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-apache-logformat-compiler
+#
+################################################################################
+
+PERL_APACHE_LOGFORMAT_COMPILER_VERSION = 0.35
+PERL_APACHE_LOGFORMAT_COMPILER_SOURCE = Apache-LogFormat-Compiler-$(PERL_APACHE_LOGFORMAT_COMPILER_VERSION).tar.gz
+PERL_APACHE_LOGFORMAT_COMPILER_SITE = $(BR2_CPAN_MIRROR)/authors/id/K/KA/KAZEBURO
+PERL_APACHE_LOGFORMAT_COMPILER_DEPENDENCIES = host-perl-module-build-tiny perl-posix-strftime-compiler
+PERL_APACHE_LOGFORMAT_COMPILER_LICENSE = Artistic or GPL-1.0+
+PERL_APACHE_LOGFORMAT_COMPILER_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))