linux: add linux-update-config and linux-update-defconfig targets
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Fri, 14 Oct 2011 14:56:56 +0000 (16:56 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 11 Nov 2011 19:13:14 +0000 (20:13 +0100)
In analogy to build targets uclibc-update and busybox-update, add
extra targets to copy the current configuration to the custom
configuration file set in buildroot. These targets facilitate the
work of developers adding support for a specific board.

linux-update-config copies .config directly.
linux-update-defconfig first creates a defconfig and copies that.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 9beb706453323b6261e21f9276e5924f939006ca..5c5a1d2967c3c9fbb6275e80e50032ab975c0bd7 100644 (file)
@@ -196,6 +196,17 @@ linux-savedefconfig linux26-savedefconfig: dirs $(LINUX_DIR)/.stamp_configured
        $(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) \
                $(subst linux-,,$(subst linux26-,,$@))
 
+ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
+linux-update-config linux26-update-config: $(LINUX_DIR)/.config
+       cp -f $(LINUX_DIR)/.config $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)
+
+linux-update-defconfig linux26-update-defconfig: linux-savedefconfig
+       cp -f $(LINUX_DIR)/defconfig $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)
+else
+linux-update-config linux26-update-config: ;
+linux-update-defconfig linux26-update-defconfig: ;
+endif
+
 # Support for rebuilding the kernel after the cpio archive has
 # been generated in $(BINARIES_DIR)/rootfs.cpio.
 $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LINUX_DIR)/.stamp_images_installed $(BINARIES_DIR)/rootfs.cpio