external-toolchain: adjust check for uClibc static toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 31 Dec 2011 15:15:43 +0000 (16:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Mar 2012 19:26:38 +0000 (20:26 +0100)
The current check for uClibc toolchain was verifying that a
ld-uClibc.so dynamic loader was present. However, with static-only
uClibc toolchains, this does not work. Instead, we check for an
uClibc-specific header file in the sysroot.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/helpers.mk

index 3f4818f2264137d07f06961892e64f8cfedcdbd2..6e7f1f4c9d77ed4410383380bf21953b8171cdc9 100644 (file)
@@ -196,7 +196,7 @@ check_uclibc_feature = \
 #
 check_uclibc = \
        SYSROOT_DIR="$(strip $1)"; \
-       if ! test -f $${SYSROOT_DIR}/lib/ld*-uClibc.so.* ; then \
+       if ! test -f $${SYSROOT_DIR}/usr/include/bits/uClibc_config.h ; then \
                echo "Incorrect selection of the C library"; \
                exit -1; \
        fi; \