package/sofia-sip: fix static build with openssl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 13 Sep 2020 16:52:25 +0000 (18:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 Sep 2020 19:59:44 +0000 (21:59 +0200)
Use --with-openssl=pkg-config otherwise sofia-sip will fail to retrieve
openssl dependencies resulting in the following build failure:

/srv/storage/autobuild/run/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/8.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: ../libsofia-sip-ua/.libs/libsofia-sip-ua.a(tport_type_ws.o): in function `tport_ws_deinit_primary':
tport_type_ws.c:(.text+0x2c): undefined reference to `SSL_CTX_free'
/srv/storage/autobuild/run/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/8.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: ../libsofia-sip-ua/.libs/libsofia-sip-ua.a(tport_type_ws.o): in function `tport_ws_init_primary_secure':

pkg-config option has been added to freeswitch sofia-sip since 2007 and
https://github.com/freeswitch/sofia-sip/commit/044ac9d8fa7e840cf3e38c3fa7f8cacd0d21b3ea

Fixes:
 - http://autobuild.buildroot.org/results/8a0c9dbad74a3b358f90c7a3b56b638c4bdb8045

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sofia-sip/sofia-sip.mk

index 54b48a70486984387114409aa38fb0b908c94ada..0ce0340d87e050fec35474339bddd22fb4fd5512 100644 (file)
@@ -20,7 +20,7 @@ SOFIA_SIP_CONF_OPTS += --without-glib
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
-SOFIA_SIP_CONF_OPTS += --with-openssl
+SOFIA_SIP_CONF_OPTS += --with-openssl=pkg-config
 SOFIA_SIP_DEPENDENCIES += openssl
 else
 SOFIA_SIP_CONF_OPTS += --without-openssl