sdl_net: fix install options for target and staging
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 25 Sep 2008 06:13:24 +0000 (06:13 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 25 Sep 2008 06:13:24 +0000 (06:13 -0000)
This patch install with install-strip to the target and uses the default for
installing to staging. Makes the makefile even more compact, and also more
correct with using install-strip to get proper stripping of the installed
library.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/sdl_net/sdl_net.mk

index 144d02df67ffadbdb1aa41d098d5773ed1e21691..57cd259f62dd93df6f02c8158e55b3391f17befb 100644 (file)
@@ -11,9 +11,7 @@ SDL_NET_CONF_OPT = --localstatedir=/var \
                --with-sdl-exec-prefix=$(STAGING_DIR)/usr
 
 SDL_NET_INSTALL_STAGING = YES
-SDL_NET_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install
-
-SDL_NET_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
+SDL_NET_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-strip
 
 SDL_NET_DEPENDENCIES = sdl