sqlcipher: fix passing CFLAGS/LDFLAGS to configure
authorMax Filippov <jcmvbkbc@gmail.com>
Mon, 12 May 2014 03:27:03 +0000 (07:27 +0400)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 12 May 2014 20:48:58 +0000 (22:48 +0200)
SQLCIPHER_CONF_ENV is a string used to pass environment variables to the
confgiure script, '+=' operator doesn't have any special meaning inside
it, so CFLAGS+=... is passed to shell, overwriting previous CFLAGS
value. Replace CFLAGS+="..." with CFLAGS="$(TARGET_CFLAGS) ...".

Fixes:
  http://autobuild.buildroot.net/results/dbf/dbf947ad6442fa8e57201ffcc96871361bf39ad7/

Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sqlcipher/sqlcipher.mk

index 6130870bba1f434b1964f83cd3623c9ce8c87dab..bae59bb63fa7849335302c01c8036f3e375e9a51 100644 (file)
@@ -10,8 +10,8 @@ SQLCIPHER_DEPENDENCIES = openssl host-tcl
 SQLCIPHER_INSTALL_STAGING = YES
 
 SQLCIPHER_CONF_ENV = \
-       CFLAGS+=" $(SQLCIPHER_CFLAGS)" \
-       LDFLAGS+=" $(SQLCIPHER_LDFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) $(SQLCIPHER_CFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS) $(SQLCIPHER_LDFLAGS)" \
        TCLSH_CMD=$(HOST_DIR)/usr/bin/tclsh$(TCL_VERSION_MAJOR)
 
 SQLCIPHER_CONF_OPT = \