supervisor: convert to the Python package infrastructure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Dec 2013 20:26:55 +0000 (21:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 12:41:23 +0000 (13:41 +0100)
Remove the select of BR2_PACKAGE_PYTHON_SETUPTOOLS, since what is
really needed is host-setuptools (as can be seen from the original .mk
file), and not setuptools for the target.

Also, remove the mangling of the Python shebang, since it's now done
by passing the --executable= option at install time (done in the
Python package infrastructure).

Finally, convert the package to use <pkg>_INSTALL_INIT_SYSV.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/supervisor/Config.in
package/supervisor/supervisor.mk

index 53401810f3099c17a94bb24020c0d2f41cbed726..c511dd87057862394b83e893a830f3ba30e609d8 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_SUPERVISOR
        bool "supervisor"
        depends on BR2_PACKAGE_PYTHON
-       select BR2_PACKAGE_PYTHON_SETUPTOOLS
        select BR2_PACKAGE_PYTHON_MELD3
        help
          A client/server system that allows its users to control a
index 40ad8ce3a9de7a28449247009381196625923d99..d2d58e2c853f928f489c43b661682ae21e67b753 100644 (file)
@@ -7,19 +7,19 @@
 SUPERVISOR_VERSION = 3.0a12
 SUPERVISOR_SITE = http://pypi.python.org/packages/source/s/supervisor/
 SUPERVISOR_LICENSE_FILES = LICENSES.txt
+SUPERVISOR_SETUP_TYPE = setuptools
 
-SUPERVISOR_DEPENDENCIES = python host-python-setuptools
-
-define SUPERVISOR_BUILD_CMDS
-       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+define SUPERVISOR_INSTALL_CONF_FILES
+       $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
+       $(INSTALL) -D -m 644 package/supervisor/supervisord.conf \
+               $(TARGET_DIR)/etc/supervisord.conf
 endef
 
-define SUPERVISOR_INSTALL_TARGET_CMDS
-       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=/usr --root=$(TARGET_DIR))
-       sed -i '1s|#!.*python.*|#!/usr/bin/env python|' $(TARGET_DIR)/usr/bin/{echo_supervisord_conf,pidproxy,supervisorctl,supervisord}
-       $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
-       $(INSTALL) -D -m 644 package/supervisor/supervisord.conf $(TARGET_DIR)/etc/supervisord.conf
-       $(INSTALL) -m 755 package/supervisor/S99supervisord $(TARGET_DIR)/etc/init.d/S99supervisord
+SUPERVISOR_POST_INSTALL_TARGET_HOOKS += SUPERVISOR_INSTALL_CONF_FILES
+
+define SUPERVISOR_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 755 package/supervisor/S99supervisord \
+               $(TARGET_DIR)/etc/init.d/S99supervisord
 endef
 
-$(eval $(generic-package))
+$(eval $(python-package))