gupnp-dlna: new package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 28 Jul 2016 08:12:38 +0000 (10:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 30 Jul 2016 13:36:22 +0000 (15:36 +0200)
GUPnP DLNA is a small utility library that aims to ease the
DLNA-related tasks such as media profile guessing, transcoding
to a given profile, etc.

http://www.gupnp.org/

Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/gupnp-dlna/Config.in [new file with mode: 0644]
package/gupnp-dlna/gupnp-dlna.hash [new file with mode: 0644]
package/gupnp-dlna/gupnp-dlna.mk [new file with mode: 0644]

index 27b934a97f98fd78efdf538a17accc93da77cf73..f11ea9f285efdd82d9994f5be6636758477c694c 100644 (file)
@@ -1165,6 +1165,7 @@ menu "Networking"
        source "package/gssdp/Config.in"
        source "package/gupnp/Config.in"
        source "package/gupnp-av/Config.in"
+       source "package/gupnp-dlna/Config.in"
        source "package/ibrcommon/Config.in"
        source "package/ibrdtn/Config.in"
        source "package/libcgi/Config.in"
diff --git a/package/gupnp-dlna/Config.in b/package/gupnp-dlna/Config.in
new file mode 100644 (file)
index 0000000..a0ecdb3
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_GUPNP_DLNA
+       bool "gupnp-dlna"
+       depends on BR2_USE_WCHAR # glib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
+       depends on BR2_USE_MMU # glib2
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_LIBXML2
+       help
+         GUPnP DLNA is a small utility library that aims to ease the
+         DLNA-related tasks such as media profile guessing, transcoding
+         to a given profile, etc.
+
+         http://www.gupnp.org/
+
+comment "gupnp-dlna needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/gupnp-dlna/gupnp-dlna.hash b/package/gupnp-dlna/gupnp-dlna.hash
new file mode 100644 (file)
index 0000000..c28a06f
--- /dev/null
@@ -0,0 +1,2 @@
+# Hash from: http://ftp.gnome.org/pub/gnome/sources/gupnp-dlna/0.10/gupnp-dlna-0.10.5.sha256sum:
+sha256 123e368227c11d5c17fc1aa76cbdaffa345355eb51d172cd39fc74a5b468ff6a        gupnp-dlna-0.10.5.tar.xz
diff --git a/package/gupnp-dlna/gupnp-dlna.mk b/package/gupnp-dlna/gupnp-dlna.mk
new file mode 100644 (file)
index 0000000..58b5735
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# gupnp-dlna
+#
+################################################################################
+
+GUPNP_DLNA_VERSION_MAJOR = 0.10
+GUPNP_DLNA_VERSION = $(GUPNP_DLNA_VERSION_MAJOR).5
+GUPNP_DLNA_SOURCE = gupnp-dlna-$(GUPNP_DLNA_VERSION).tar.xz
+GUPNP_DLNA_SITE = \
+       http://ftp.gnome.org/pub/gnome/sources/gupnp-dlna/$(GUPNP_DLNA_VERSION_MAJOR)
+# COPYING contains LGPLv2.1 but all source files contain LPGLv2+
+GUPNP_DLNA_LICENSE = LGPLv2+
+GUPNP_DLNA_LICENSE_FILES = COPYING
+GUPNP_DLNA_INSTALL_STAGING = YES
+GUPNP_DLNA_DEPENDENCIES = host-pkgconf libglib2 libxml2
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
+GUPNP_DLNA_CONF_OPTS += --enable-legacy-gstreamer-metadata-backend
+GUPNP_DLNA_DEPENDENCIES += gstreamer gst-plugins-base
+else
+GUPNP_DLNA_CONF_OPTS += --disable-legacy-gstreamer-metadata-backend
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
+GUPNP_DLNA_CONF_OPTS += --enable-gstreamer-metadata-backend
+GUPNP_DLNA_DEPENDENCIES += gstreamer1 gst1-plugins-base
+else
+GUPNP_DLNA_CONF_OPTS += --disable-gstreamer-metadata-backend
+endif
+
+$(eval $(autotools-package))