pciutils: fix access to pci.ids and make update-pciids work with busybox wget
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 24 May 2010 06:22:26 +0000 (08:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 24 May 2010 06:22:26 +0000 (08:22 +0200)
Closes #1819

Fix two issues with pciutils:

- pciutils would look in /usr/share/misc for pci.ids, but install it in
  /usr/share. This is because pciutils doesn't use a ./configure script,
  so we have to also provide the configuration (make) arguments when
  we run make install as well. Fix it by making it look into /usr/share
  as that's simpler to do, and is what upstream does.

- the update-pciids script would call wget with the --no-timestamping
  option, which isn't supported by busybox wget. Fix it by simply
  removing that option as it isn't really critical.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/pciutils/pciutils.mk

diff --git a/CHANGES b/CHANGES
index 72b21584c3625282894fc42c9309371aa5b7525a..4d0046355d4595dfe9fdb09df618f385508f9402 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -5,14 +5,16 @@
        Updated/fixed packages: aumix, avahi, busybox, cairo, cdrkit,
        fltk, gettext, gmpc, grep, hal, iconv, icu, libcgicc, libglib2,
        libidn, libmpd, libpcap, libsoup, lmbench, ltrace, lvm2, make,
-       mtd-utils, mutt, netsnmp, ntp, pango, php, psmisc, qt, samba,
-       sshfs, startup-notification, uemacs, util-linux, vpnc
+       mtd-utils, mutt, netsnmp, ntp, pango, pciutils, php, psmisc,
+       qt, samba, sshfs, startup-notification, uemacs, util-linux,
+       vpnc
 
        Issues resolved (http://bugs.uclibc.org):
 
        #1693: NTP trys IPV6 even if not configured error: 'IPV6_MULTICAST...
        #1729: alsamixergui fails to build
        #1801: Avahi-autoipd doesn't create TARGET_DIR/var/lib
+       #1819: pciutils small bugs
 
 2010.05-rc2, Released May 11th, 2010:
 
index 2b999dfb59e986b8269d7085bf93d515b832b339..a7d999664f867839f4852bf8b9d550f64de58da3 100644 (file)
@@ -15,6 +15,7 @@ PCIUTILS_DNS=no
 PCIUTILS_SHARED=yes
 
 define PCIUTILS_CONFIGURE_CMDS
+       $(SED) 's/wget --no-timestamping/wget/' $(PCIUTILS_DIR)/update-pciids.sh
        $(SED) 's/uname -s/echo Linux/' \
                -e 's/uname -r/echo $(LINUX_HEADERS_VERSION)/' \
                $(PCIUTILS_DIR)/lib/configure
@@ -32,7 +33,7 @@ define PCIUTILS_BUILD_CMDS
                SHARED=$(PCIUTILS_SHARED) \
                ZLIB=$(PCIUTILS_ZLIB) \
                DNS=$(PCIUTILS_DNS) \
-               SHAREDIR=/usr/share/misc
+               PREFIX=/usr
 endef
 
 # Ditch install-lib if SHARED is an option in the future