perl-sub-install: new package
authorChristopher McCrory <chrismcc@gmail.com>
Fri, 10 Aug 2018 16:14:59 +0000 (09:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Aug 2018 09:53:14 +0000 (11:53 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-sub-install/Config.in [new file with mode: 0644]
package/perl-sub-install/perl-sub-install.hash [new file with mode: 0644]
package/perl-sub-install/perl-sub-install.mk [new file with mode: 0644]

index 95611897c056eea5b083a1029b855d0753dc07ff..9905d9dd5dc01fe734b8ecf74ea4ee287b8e81a3 100644 (file)
@@ -494,6 +494,7 @@ F:  package/perl-json-maybexs/
 F:     package/perl-module-runtime/
 F:     package/perl-number-bytes-human/
 F:     package/perl-params-util/
+F:     package/perl-sub-install/
 
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
index ccc79090d7f1d7811ea55b233bedc4732900b20d..354145184099d3d8614965ac3c5c48bd6c91510c 100644 (file)
@@ -721,6 +721,7 @@ menu "Perl libraries/modules"
        source "package/perl-number-bytes-human/Config.in"
        source "package/perl-params-util/Config.in"
        source "package/perl-path-tiny/Config.in"
+       source "package/perl-sub-install/Config.in"
        source "package/perl-time-hires/Config.in"
        source "package/perl-timedate/Config.in"
        source "package/perl-try-tiny/Config.in"
diff --git a/package/perl-sub-install/Config.in b/package/perl-sub-install/Config.in
new file mode 100644 (file)
index 0000000..41d57b2
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PERL_SUB_INSTALL
+       bool "perl-sub-install"
+       help
+         install subroutines into packages easily
+
+         https://github.com/rjbs/Sub-Install
diff --git a/package/perl-sub-install/perl-sub-install.hash b/package/perl-sub-install/perl-sub-install.hash
new file mode 100644 (file)
index 0000000..3abd994
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    e1ce4f9cb6b2f6b8778b036c31afa5ab Sub-Install-0.928.tar.gz
+sha256 61e567a7679588887b7b86d427bc476ea6d77fffe7e0d17d640f89007d98ef0f Sub-Install-0.928.tar.gz
+
+# computed by scancpan
+sha256 ad5fb5c05003488f924c60ead21694d629055c9db2ee2d9dd0cf0041b9fedaca LICENSE
diff --git a/package/perl-sub-install/perl-sub-install.mk b/package/perl-sub-install/perl-sub-install.mk
new file mode 100644 (file)
index 0000000..fc7c55a
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# perl-sub-install
+#
+################################################################################
+
+PERL_SUB_INSTALL_VERSION = 0.928
+PERL_SUB_INSTALL_SOURCE = Sub-Install-$(PERL_SUB_INSTALL_VERSION).tar.gz
+PERL_SUB_INSTALL_SITE = $(BR2_CPAN_MIRROR)/authors/id/R/RJ/RJBS
+PERL_SUB_INSTALL_LICENSE = Artistic or GPL-1.0+
+PERL_SUB_INSTALL_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))