cups: rename patches to follow BR guidelines
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 5 Mar 2014 15:30:01 +0000 (15:30 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Mar 2014 23:45:27 +0000 (00:45 +0100)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cups/cups-0002-fix-stack-protector-check.patch [new file with mode: 0644]
package/cups/cups-0003-mantohtml.patch [new file with mode: 0644]
package/cups/cups-fix-stack-protector-check.patch [deleted file]
package/cups/cups-mantohtml.patch [deleted file]

diff --git a/package/cups/cups-0002-fix-stack-protector-check.patch b/package/cups/cups-0002-fix-stack-protector-check.patch
new file mode 100644 (file)
index 0000000..1db35ff
--- /dev/null
@@ -0,0 +1,25 @@
+[PATCH]: use AC_TRY_LINK for stack protector check
+
+Actually try to link an executable to test for stack protector support,
+as gcc seems to accept the -fstack-protector argument even when it's
+compiled with --disable-libssp (but linking fails with a error
+finding -lssp_nonshared).
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config-scripts/cups-compiler.m4 |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: cups-1.3.9/config-scripts/cups-compiler.m4
+===================================================================
+--- cups-1.3.9.orig/config-scripts/cups-compiler.m4
++++ cups-1.3.9/config-scripts/cups-compiler.m4
+@@ -109,7 +109,7 @@ if test -n "$GCC"; then
+       AC_MSG_CHECKING(if GCC supports -fstack-protector)
+       OLDCFLAGS="$CFLAGS"
+       CFLAGS="$CFLAGS -fstack-protector"
+-      AC_TRY_COMPILE(,,
++      AC_TRY_LINK(,,
+               OPTIM="$OPTIM -fstack-protector"
+               AC_MSG_RESULT(yes),
+               AC_MSG_RESULT(no))
diff --git a/package/cups/cups-0003-mantohtml.patch b/package/cups/cups-0003-mantohtml.patch
new file mode 100644 (file)
index 0000000..e6a10b0
--- /dev/null
@@ -0,0 +1,11 @@
+--- cups-1.3.5/man/Makefile    2007-07-12 21:01:14.000000000 -0400
++++ cups-1.3.5/man/Makefile    2008-02-11 08:55:24.000000000 -0500
+@@ -173,7 +173,7 @@ html:      $(MAN1) $(MAN5) $(MAN7) $(MAN8) ma
+       done
+ mantohtml:    mantohtml.o
+-      $(CC) $(LDFLAGS) -o $@ mantohtml.o
++      gcc -I/usr/include -I../ -L/usr/lib mantohtml.c -o mantohtml
+ #
diff --git a/package/cups/cups-fix-stack-protector-check.patch b/package/cups/cups-fix-stack-protector-check.patch
deleted file mode 100644 (file)
index 1db35ff..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-[PATCH]: use AC_TRY_LINK for stack protector check
-
-Actually try to link an executable to test for stack protector support,
-as gcc seems to accept the -fstack-protector argument even when it's
-compiled with --disable-libssp (but linking fails with a error
-finding -lssp_nonshared).
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- config-scripts/cups-compiler.m4 |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: cups-1.3.9/config-scripts/cups-compiler.m4
-===================================================================
---- cups-1.3.9.orig/config-scripts/cups-compiler.m4
-+++ cups-1.3.9/config-scripts/cups-compiler.m4
-@@ -109,7 +109,7 @@ if test -n "$GCC"; then
-       AC_MSG_CHECKING(if GCC supports -fstack-protector)
-       OLDCFLAGS="$CFLAGS"
-       CFLAGS="$CFLAGS -fstack-protector"
--      AC_TRY_COMPILE(,,
-+      AC_TRY_LINK(,,
-               OPTIM="$OPTIM -fstack-protector"
-               AC_MSG_RESULT(yes),
-               AC_MSG_RESULT(no))
diff --git a/package/cups/cups-mantohtml.patch b/package/cups/cups-mantohtml.patch
deleted file mode 100644 (file)
index e6a10b0..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- cups-1.3.5/man/Makefile    2007-07-12 21:01:14.000000000 -0400
-+++ cups-1.3.5/man/Makefile    2008-02-11 08:55:24.000000000 -0500
-@@ -173,7 +173,7 @@ html:      $(MAN1) $(MAN5) $(MAN7) $(MAN8) ma
-       done
- mantohtml:    mantohtml.o
--      $(CC) $(LDFLAGS) -o $@ mantohtml.o
-+      gcc -I/usr/include -I../ -L/usr/lib mantohtml.c -o mantohtml
- #