dnsmasq: create runtime directory
authorDaniel Mack <zonque@gmail.com>
Fri, 2 Dec 2011 10:49:11 +0000 (11:49 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 6 Dec 2011 08:49:09 +0000 (09:49 +0100)
$(TARGET_DIR)/var/lib/misc/ is the location where dnsmasq stores its
lease files. Create it to make the daemon work.

Signed-off-by: Daniel Mack <zonque@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dnsmasq/dnsmasq.mk

index 0f8db9d68d8581ead75170c8ae1586c1d5d2de12..fc43abdf0ec4bdec7c86ef2e14a6b9a3db123697 100644 (file)
@@ -57,6 +57,7 @@ endef
 
 define DNSMASQ_INSTALL_TARGET_CMDS
        $(DNSMASQ_MAKE_ENV) $(MAKE) -C $(@D) $(DNSMASQ_MAKE_OPT) install
+       mkdir -p $(TARGET_DIR)/var/lib/misc/
 endef
 
 define DNSMASQ_UNINSTALL_TARGET_CMDS