package/libupnp18: add config option --enable-reuseaddr
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 9 Jan 2020 10:32:41 +0000 (11:32 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 9 Jan 2020 16:40:00 +0000 (17:40 +0100)
Enable the option to use SO_REUSEADDR on the built-in miniserver
socket to allow clean restarts [1].

This fixes a runtime issue with Gerbera and possible other programs
which does not allow a graceful restart otherwise.

[1] https://github.com/pupnp/pupnp/commit/629dec75610260a669c7c3ed40c9332b7917b562

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libupnp18/libupnp18.mk

index ca82a54413457ad0d4fb2edb29d3680dbb440346..f73c656831909299c5f40c547125b2ec4fbfe429 100644 (file)
@@ -13,6 +13,9 @@ LIBUPNP18_LICENSE = BSD-3-Clause
 LIBUPNP18_LICENSE_FILES = COPYING
 LIBUPNP18_DEPENDENCIES = host-pkgconf
 
+# Bind the internal miniserver socket with reuseaddr to allow clean restarts.
+LIBUPNP18_CONF_OPTS += --enable-reuseaddr
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBUPNP18_CONF_OPTS += --enable-open-ssl
 LIBUPNP18_DEPENDENCIES += openssl