package/tvheadend: add option to enable Satellite/IP support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 4 Apr 2021 12:09:32 +0000 (14:09 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 4 Apr 2021 12:22:37 +0000 (14:22 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[yann.morin.1998@free.fr: one option per-commit]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/tvheadend/Config.in
package/tvheadend/tvheadend.mk

index 414892cd9e7da09e9907876a5034d8e5422849e4..d96d19989890914d715ea301e4f519493dd39911 100644 (file)
@@ -34,6 +34,12 @@ config BR2_PACKAGE_TVHEADEND_DESCRAMBLER
        help
          Enable support for various descrambler modules.
 
+config BR2_PACKAGE_TVHEADEND_SATIP
+       bool "SAT>IP support"
+       default y
+       help
+         Enable SAT>IP support.
+
 config BR2_PACKAGE_TVHEADEND_TRANSCODING
        bool "transcoding support"
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
index 4043d73386ac69cf16e535c5f489358263d7d70f..9a007ce8d1cfd2a89eacac33c30dce3c420c1b32 100644 (file)
@@ -79,6 +79,12 @@ TVHEADEND_CONF_OPTS += \
        --disable-constcw
 endif
 
+ifeq ($(BR2_PACKAGE_TVHEADEND_SATIP),y)
+TVHEADEND_CONF_OPTS += --enable-satip_client --enable-satip_server
+else
+TVHEADEND_CONF_OPTS += --disable-satip_client --disable-satip_server
+endif
+
 ifeq ($(BR2_PACKAGE_LIBDVBCSA),y)
 TVHEADEND_DEPENDENCIES += libdvbcsa
 TVHEADEND_CONF_OPTS += --enable-tvhcsa