linknx: forcilbly disable smtp support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 3 Apr 2013 00:27:58 +0000 (00:27 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 3 Apr 2013 20:40:55 +0000 (22:40 +0200)
linknx has support for SMTP via libesmtp, however there's no clean way
to specify where libesmtp-config lives.
So when libesmtp is built it finds it via the headers and is
automatically enabled, but it fails to get the appropiate link line from
libesmtp-config because it's not found.
Fix it by forcibly disabling it. If someone is interested in working
with upstream about this an option like --with-libcurl should be
implemented in configure.
Solves:
http://autobuild.buildroot.net/results/90ebb383d7a2d7bdf09ffac65e2504da7b6d19f5/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/linknx/linknx.mk

index 42700a717c3e453d7791f741f2572e9e3e7d0757..54e04267cd44ba970d26be547e83bf05bf61d573 100644 (file)
@@ -9,7 +9,7 @@ LINKNX_SITE = http://downloads.sourceforge.net/project/linknx/linknx/linknx-$(LI
 LINKNX_LICENSE = GPLv2+
 LINKNX_INSTALL_STAGING = YES
 LINKNX_CONF_OPT = --without-lua --without-log4cpp --without-pth-test \
-                 --with-pth=$(STAGING_DIR)/usr
+                 --with-pth=$(STAGING_DIR)/usr --disable-smtp
 
 LINKNX_DEPENDENCIES = libpthsem