- hit awk on steroids with a clue bait
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 6 Apr 2007 15:01:32 +0000 (15:01 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 6 Apr 2007 15:01:32 +0000 (15:01 -0000)
package/openssl/openssl.mk

index 00baeddb761f544bc25d2df97067827803bb5f27..1b220bbb9f72c0b01cbe455a52696e03210056a2 100644 (file)
@@ -32,9 +32,10 @@ $(OPENSSL_DIR)/.unpacked: $(DL_DIR)/$(OPENSSL_SOURCE)
        $(OPENSSL_CAT) $(DL_DIR)/$(OPENSSL_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        toolchain/patch-kernel.sh $(OPENSSL_DIR) package/openssl/ openssl\*.patch
        # sigh... we have to resort to this just to set a gcc flag.
+       # grumble.. and of course make sure to escape any '/' in CFLAGS
        $(SED) 's,/CFLAG=,/CFLAG= $(TARGET_SOFT_FLOAT) ,g' \
                $(OPENSSL_DIR)/Configure
-       $(SED) '/CFLAG=/s,/;, $(TARGET_CFLAGS)/;,' \
+       $(SED) '/CFLAG=/s,/;, $(shell echo '$(TARGET_CFLAGS)' | sed -e 's/\//\\\\\//g')/;,' \
                $(OPENSSL_DIR)/Configure
        touch $(OPENSSL_DIR)/.unpacked