gzip: fix installation path
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 6 Jan 2015 14:42:29 +0000 (11:42 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Jan 2015 20:17:19 +0000 (21:17 +0100)
Make gzip install binaries to / rather than /usr to fix bug #7766, it's
the FHS mandated target.

This also avoids duplicating binaries with busybox when both are
installed.

Also make gzip install after busybox if both are enabled to make the
proper gzip package override any busybox version since it's usually more
lightweight in functionality and slower.

And add a hash file while at it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gzip/gzip.hash [new file with mode: 0644]
package/gzip/gzip.mk

diff --git a/package/gzip/gzip.hash b/package/gzip/gzip.hash
new file mode 100644 (file)
index 0000000..56f052f
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated after checking pgp signature
+sha256 37dfed1a485d53212c43b3fa2a7c7952f09bf5cd86e37121c222341ee1b27847  gzip-1.6.tar.xz
index e1a7befdb10e7e26e333ad3bd6bef3373340b3f3..4ae2ae03daeeeacb5c4b73db1e280442907ad0f5 100644 (file)
@@ -7,6 +7,10 @@
 GZIP_VERSION = 1.6
 GZIP_SOURCE = gzip-$(GZIP_VERSION).tar.xz
 GZIP_SITE = $(BR2_GNU_MIRROR)/gzip
+# Some other tools expect it to be in /bin
+GZIP_CONF_OPTS = --exec-prefix=/
+# Prefer full gzip over potentially lightweight/slower from busybox
+GZIP_DEPENDENCIES = $(if $(BR2_PACKAGE_BUSYBOX),busybox)
 GZIP_LICENSE = GPLv3+
 GZIP_LICENSE_FILES = COPYING