libsoc: bump to 0.4
authorYegor Yefremov <yegorslists@googlemail.com>
Tue, 8 Oct 2013 07:11:55 +0000 (09:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 8 Oct 2013 15:08:14 +0000 (17:08 +0200)
"Non-blocking GPIO Interrupts with callback mechanism" feature
requires pthreads.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libsoc/Config.in
package/libsoc/libsoc.mk

index 3e750bd0fd2687586eed8c991b787c29654b1167..0f6336de1ccdcfc20a7494289b113b24d3326a32 100644 (file)
@@ -1,7 +1,11 @@
 config BR2_PACKAGE_LIBSOC
        bool "libsoc"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
        help
          libsoc is a C library for interfacing with common SoC
          peripherals through generic kernel interfaces
 
          https://github.com/jackmitch/libsoc
+
+comment "libsoc requires a toolchain with threads support"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
index 509d8eb061116946d6dcfa54a4cab16b38d9744a..79c7e9000640d26a2852a62af2170c5e3b974d27 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBSOC_VERSION = 356760dcb93b22d6c67c5232cde2ade8c968c932
+LIBSOC_VERSION = 0.4
 LIBSOC_SITE = http://github.com/jackmitch/libsoc/tarball/$(LIBSOC_VERSION)
 LIBSOC_LICENSE = LGPLv2.1
 LIBSOC_LICENSE_FILES = COPYING