xorriso: disable libcdio
authorBaruch Siach <baruch@tkos.co.il>
Sat, 22 Apr 2017 20:10:44 +0000 (23:10 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Apr 2017 07:58:49 +0000 (09:58 +0200)
xorriso and libcdio define identically named symbols. This breaks static
linking.

Besides, upstream suggested that on Linux the built-in libburn adapter is much
better tested than libcdio.

Disable libcdio.

Fixes:
http://autobuild.buildroot.net/results/430/430a6b548fcc311f20ea71cecaa11fafac1d5a19/
http://autobuild.buildroot.net/results/a5d/a5d0f8bec0d39e48f6dfe4ecc07fe0ca3c6bd70a/

Cc: Steve Kenton <skenton@ou.edu>
Suggested-by: Thomas Schmitt <scdbackup@gmx.net>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Acked-by: Steve Kenton <skenton@ou.edu>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xorriso/xorriso.mk

index b2055804302efbb64bd6cb5bd06637742d6aeb66..1f095911f80fa570c0b79847ba26e8256c3bee10 100644 (file)
@@ -18,19 +18,14 @@ HOST_XORRISO_CONF_OPTS = \
        --disable-libedit \
        --disable-libacl
 
+# libcdio doesn't make sense for Linux
+# http://lists.gnu.org/archive/html/bug-xorriso/2017-04/msg00004.html
+XORRISO_CONF_OPTS = --disable-libcdio
+
 ifeq ($(BR2_PACKAGE_LIBICONV),y)
 XORRISO_DEPENDENCIES += libiconv
 endif
 
-ifeq ($(BR2_PACKAGE_LIBCDIO),y)
-XORRISO_DEPENDENCIES += host-pkgconf libcdio
-XORRISO_CONF_OPTS += \
-       --enable-pkg-check-modules \
-       --enable-libcdio
-else
-XORRISO_CONF_OPTS += --disable-libcdio
-endif
-
 ifeq ($(BR2_PACKAGE_READLINE),y)
 XORRISO_DEPENDENCIES += readline
 XORRISO_CONF_OPTS += --enable-libreadline