lzma: remove deprecated target package
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Tue, 21 Jan 2014 07:54:12 +0000 (08:54 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 21 Jan 2014 20:58:07 +0000 (21:58 +0100)
The on-target lzma package has been deprecated for a long time, so remove
it. This does not remove the support for generating lzma-compressed rootfs
images.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in
Config.in.legacy
package/Config.in
package/lzma/Config.in [deleted file]
package/lzma/lzma.mk

index fa723fe0a0efbb7e77e0e9b5c9bb0f7de098ff38..7ec7c2ab48ebbe8c62bc0757d45b46441df2172e 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -264,10 +264,6 @@ config BR2_DEPRECATED
 
 if BR2_DEPRECATED
 
-config BR2_DEPRECATED_SINCE_2010_11
-       bool
-       default y
-
 config BR2_DEPRECATED_SINCE_2012_11
        bool
        default y
index 473d0efee203f1437e555674c33ad2cfa714117e..631286ae9717386b26facb96e960477fb1a6a205 100644 (file)
@@ -101,6 +101,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.02"
 
+config BR2_PACKAGE_LZMA
+       bool "lzma target package has been removed"
+       select BR2_LEGACY
+       help
+         The 'lzma' target package has been removed since it has been
+         deprecated for more than four buildroot releases.
+         Note: generating lzma-compressed rootfs images is still supported.
+
 config BR2_PACKAGE_TTCP
        bool "ttcp has been removed"
        select BR2_LEGACY
index ed31354205ff63f9d3147a84e297ddd786ce765c..c45f8bd166b379c0ffbc0e2958b58586062358cf 100644 (file)
@@ -35,7 +35,6 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/gzip/Config.in"
 endif
 source "package/infozip/Config.in"
-source "package/lzma/Config.in"
 source "package/lzop/Config.in"
 source "package/xz/Config.in"
 endmenu
diff --git a/package/lzma/Config.in b/package/lzma/Config.in
deleted file mode 100644 (file)
index d7e8827..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-config BR2_PACKAGE_LZMA
-       bool "lzma"
-       depends on BR2_INSTALL_LIBSTDCPP
-       depends on BR2_DEPRECATED_SINCE_2010_11
-       help
-         Lempel Ziv compression method (LZMA) is a compression
-         algorithm with high compression ratio.
-
-         http://tukaani.org/lzma/
-
-comment "lzma needs a toolchain w/ C++"
-       depends on BR2_DEPRECATED_SINCE_2010_11
-       depends on !BR2_INSTALL_LIBSTDCPP
index 90498334df63f09cbaf8c5e0d79cd5376230b42c..e7129dd5189b45e90ce117fb1cf213df2725f835 100644 (file)
@@ -7,10 +7,8 @@
 LZMA_VERSION = 4.32.7
 LZMA_SOURCE = lzma-$(LZMA_VERSION).tar.xz
 LZMA_SITE = http://tukaani.org/lzma/
-LZMA_INSTALL_STAGING = YES
 LZMA_CONF_OPT = $(if $(BR2_ENABLE_DEBUG),--enable-debug,--disable-debug)
 
-$(eval $(autotools-package))
 $(eval $(host-autotools-package))
 
 LZMA = $(HOST_DIR)/usr/bin/lzma