micropython: replace local fix with upstream one
authorChris Packham <judge.packham@gmail.com>
Mon, 5 Sep 2016 09:16:15 +0000 (21:16 +1200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 5 Sep 2016 20:10:45 +0000 (22:10 +0200)
The fix from commit 26248571b625 ("micropython: fix build failures") was
applied upstream. This replaces the local buildroot fix with the patch
that was accepted upstream.

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/micropython/0002-py-emitglue.c-provide-mp_raw_code_load_file-for-any-.patch [deleted file]
package/micropython/micropython.hash
package/micropython/micropython.mk

diff --git a/package/micropython/0002-py-emitglue.c-provide-mp_raw_code_load_file-for-any-.patch b/package/micropython/0002-py-emitglue.c-provide-mp_raw_code_load_file-for-any-.patch
deleted file mode 100644 (file)
index 8465ce9..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From 4177e71862a2817d2555abd8d0bc9a8a361dad8a Mon Sep 17 00:00:00 2001
-From: Chris Packham <chris.packham@alliedtelesis.co.nz>
-Date: Sat, 3 Sep 2016 20:44:12 +1200
-Subject: [PATCH] py/emitglue.c: provide mp_raw_code_load_file for any unix
- architecture
-
-Signed-off-by: Chris Packham <chris.packham@alliedtelesis.co.nz>
----
- py/emitglue.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/py/emitglue.c b/py/emitglue.c
-index 1b9992b..2e79d5f 100644
---- a/py/emitglue.c
-+++ b/py/emitglue.c
-@@ -381,7 +381,7 @@ mp_raw_code_t *mp_raw_code_load_mem(const byte *buf, size_t len) {
- // here we define mp_raw_code_load_file depending on the port
- // TODO abstract this away properly
--#if defined(__i386__) || defined(__x86_64__) || defined(__aarch64__) || (defined(__arm__) && (defined(__unix__)))
-+#if defined(__i386__) || defined(__x86_64__) || defined(__aarch64__) || defined(__unix__)
- // unix file reader
- #include <sys/stat.h>
--- 
-2.9.2.518.ged577c6.dirty
-
index ea42bfb270e550efbcf68be70b669138f287ffb7..a8ad2ba4d2bd6716ff18b3ae37b1e88c5c627092 100644 (file)
@@ -1,2 +1,3 @@
 #locally computed
 sha256 871378fcf1f1042c399896d5673da67d12e1fb36c2e706af289fc959bc8f7a57  micropython-v1.8.3.tar.gz
+sha256 ff3194ebecda99023d7c1bb94d32b31b9491e95a79958a25ffd05213c5553acc  8c6856d2e76c5865d9f30cad2c51615d4a1a1418.patch
index 047e340896f99572911347a2560ee02ded32d71a..590956e8465b2dc8695f0b3d805216501b97763a 100644 (file)
@@ -9,6 +9,7 @@ MICROPYTHON_SITE = $(call github,micropython,micropython,$(MICROPYTHON_VERSION))
 MICROPYTHON_LICENSE = MIT
 MICROPYTHON_LICENSE_FILES = LICENSE
 MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
+MICROPYTHON_PATCH = https://github.com/micropython/micropython/commit/8c6856d2e76c5865d9f30cad2c51615d4a1a1418.patch
 
 # Use fallback implementation for exception handling on architectures that don't
 # have explicit support.