logrotate: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:53 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:31:09 +0000 (00:31 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/logrotate/logrotate.mk

index 2e49feb7c10595aefdfa1c24358a4ce06c787ac0..dc26d8538abe266bea2ab9d229c688b13bb49697 100644 (file)
@@ -17,9 +17,7 @@ endef
 
 define LOGROTATE_INSTALL_TARGET_CMDS
        $(MAKE) PREFIX=$(TARGET_DIR) -C $(@D) install
-       if [ ! -f $(TARGET_DIR)/etc/logrotate.conf ]; then \
-               $(INSTALL) -m 0644 package/logrotate/logrotate.conf $(TARGET_DIR)/etc/logrotate.conf; \
-       fi
+       $(INSTALL) -m 0644 package/logrotate/logrotate.conf $(TARGET_DIR)/etc/logrotate.conf
        $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/logrotate.d
 endef