libfslcodec: bump to version 4.0.7
authorGary Bisson <gary.bisson@boundarydevices.com>
Sat, 30 Jan 2016 11:45:52 +0000 (12:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 Feb 2016 20:46:08 +0000 (21:46 +0100)
Changelog since 4.0.3:
- Add mx7 SoC support.
- Add test binary to release package.
- Fix segmentation fault issue with only standard build.
- Build std only for arm11 and arm12.
- Fix some mp3_dec noise issue of c code for arm11 and arm9.

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/47b2677
https://github.com/Freescale/meta-fsl-arm/commit/c88fd22
https://github.com/Freescale/meta-fsl-arm/commit/3220a4c

This package has been implicitely tested through gstreamer as the 0.10
plugin relies on it:
 # gst-launch-0.10 playbin uri=file:///root/tears_of_steel_1080p.webm

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libfslcodec/libfslcodec.hash
package/libfslcodec/libfslcodec.mk

index 6a41be1b5bbaa3a0f9099aaacc4cbb471cf76733..d977a66a44acc4e8841536219c3f75ec74c6bac7 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed
-sha256 0d0ff933eed0a021763115b9c8ae812c6376a19bbd95e555d89ea7404f6c8f2f  libfslcodec-4.0.3.bin
+sha256 de1251286ebbc1541452f2f70fbd73e42c58f95630d65d1f9aaabf10a6caa38f  libfslcodec-4.0.7.bin
index 473d662be8d1e44f6e91e5a9e8f844e028939b61..e151c662b6d48a00d8368b962859d8c255d229e3 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBFSLCODEC_VERSION = 4.0.3
+LIBFSLCODEC_VERSION = 4.0.7
 LIBFSLCODEC_SITE = $(FREESCALE_IMX_SITE)
 LIBFSLCODEC_SOURCE = libfslcodec-$(LIBFSLCODEC_VERSION).bin
 LIBFSLCODEC_INSTALL_STAGING = YES