Pass --static rather than -static in LDFLAGS when BR2_PREFER_STATIC_LIB
authorANDY KENNEDY <ANDY.KENNEDY@adtran.com>
Mon, 5 Nov 2012 06:55:26 +0000 (06:55 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Jan 2013 19:40:26 +0000 (20:40 +0100)
The following changes LDFLAGS from -static to --static if building
with BR2_PREFER_STATIC_LIB so that various components actually build
statically.

Libtool interpret -static as linking statically with libraries that will not
be installed to the libdir; you have to pass it -all-static to force static
linking.  Or, pass --static, which libtool passes on blindly to gcc.  gcc
and (GNU) ld both interpret --static the same as -static (although this
isn't documented).

Signed-off-by: Andy Kennedy <andy.kennedy@adtran.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in

index cc8f3202c8f39ce5f4aa05f8325ffc3dc975f61c..038bd9c9cc1aed60043e10aa9cbd80a70645798c 100644 (file)
@@ -319,7 +319,7 @@ endif
 
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
 SHARED_STATIC_LIBS_OPTS=--enable-static --disable-shared
-TARGET_LDFLAGS += -static
+TARGET_LDFLAGS += --static
 else
 SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
 endif