package/mjpg-streamer: add optional dependency to zeromq
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 25 Oct 2018 19:07:32 +0000 (21:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Oct 2018 07:02:39 +0000 (08:02 +0100)
The ZeroMQ output module also depends on protobuf, see upstream PR 145.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mjpg-streamer/mjpg-streamer.mk

index de8bad0c032948c91e425229769b6885c39fe2fe..4077a3dcbc3c91beeb2b87163008e6e87cdf6622 100644 (file)
@@ -29,6 +29,13 @@ else
 MJPG_STREAMER_CONF_OPTS += -DPLUGIN_INPUT_OPENCV=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_PROTOBUF_C)$(BR2_PACKAGE_ZEROMQ),yy)
+MJPG_STREAMER_CONF_OPTS += -DPLUGIN_OUTPUT_ZMQSERVER=ON
+MJPG_STREAMER_DEPENDENCIES += host-pkgconf protobuf-c zeromq
+else
+MJPG_STREAMER_CONF_OPTS += -DPLUGIN_OUTPUT_ZMQSERVER=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_SDL),y)
 MJPG_STREAMER_CONF_OPTS += -DPLUGIN_OUTPUT_VIEWER=ON
 MJPG_STREAMER_DEPENDENCIES += host-pkgconf sdl