package/libtirpc: install full host package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 17 Jul 2021 13:44:35 +0000 (15:44 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 17 Jul 2021 14:02:44 +0000 (16:02 +0200)
Install full host package for rpc.h and all other headers to avoid the
following build failure with host-nfs-utils in version 2.5.4 raised
since commit 0ce30de72fb303768c5865949b8ce9260d0c43f5:

checking rpc/rpc.h usability... no
checking rpc/rpc.h presence... no
checking for rpc/rpc.h... no
configure: error: Header file rpc/rpc.h not found - maybe try building with --enable-tirpc

This build failure is raised by
http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=be7365239abf8556773b063730621967b9971708

Fixes:
 - http://autobuild.buildroot.org/results/a5eaf19f58729c4c00a2131b6a0c378c0fc0effb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libtirpc/libtirpc.mk

index 2678c144e9e523472f39ba8396a14c27dc698487..31be1139653a59f2e32be63cda23e6b2890a466d 100644 (file)
@@ -19,12 +19,7 @@ LIBTIRPC_AUTORECONF = YES
 LIBTIRPC_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DGQ"
 
 LIBTIRPC_CONF_OPTS = --disable-gssapi
-
-define HOST_LIBTIRPC_INSTALL_CMDS
-       $(INSTALL) -D -m 0644 $(@D)/tirpc/rpc/types.h $(HOST_DIR)/include/rpc/types.h
-       $(INSTALL) -D -m 0644 $(@D)/tirpc/netconfig.h $(HOST_DIR)/include/netconfig.h
-endef
+HOST_LIBTIRPC_CONF_OPTS = --disable-gssapi
 
 $(eval $(autotools-package))
-# We are only copying headers; no need for the autotools infrastructure
-$(eval $(host-generic-package))
+$(eval $(host-autotools-package))