package/python-aiofiles: new package
authorJugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Fri, 4 Sep 2020 14:33:00 +0000 (16:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 6 Sep 2020 18:50:41 +0000 (20:50 +0200)
Ordinary local file IO is blocking, and cannot easily and
portably made asynchronous.
This means doing file IO may interfere with asyncio applications,
which shouldn’t block the executing thread. aiofiles helps
with this y introducing asynchronous versions of files
that support delegating operations to a separate thread pool.

More information is available at :
https://pypi.org/project/aiofiles.

Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-aiofiles/Config.in [new file with mode: 0644]
package/python-aiofiles/python-aiofiles.hash [new file with mode: 0644]
package/python-aiofiles/python-aiofiles.mk [new file with mode: 0644]

index c01267960011fe09a5abd8f98126518e4e527a12..93cccef70d52898a00eb3a0e83b77eb1823416ff 100644 (file)
@@ -1424,6 +1424,7 @@ N:        Joshua Henderson <joshua.henderson@microchip.com>
 F:     package/qt5/qt5wayland/
 
 N:     Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
+F:     package/python-aiofiles/
 F:     package/python-crayons/
 F:     package/python-cycler/
 F:     package/python-matplotlib/
index e5019e3ed69f09b5bca955ff5c62ba1c9e494ca5..9d5124e838e052a69170df97d4c912f849dd501a 100644 (file)
@@ -856,6 +856,7 @@ menu "External python modules"
        source "package/python-aiocoap/Config.in"
        source "package/python-aioconsole/Config.in"
        source "package/python-aiodns/Config.in"
+       source "package/python-aiofiles/Config.in"
        source "package/python-aiohttp/Config.in"
        source "package/python-aiohttp-cors/Config.in"
        source "package/python-aiohttp-debugtoolbar/Config.in"
diff --git a/package/python-aiofiles/Config.in b/package/python-aiofiles/Config.in
new file mode 100644 (file)
index 0000000..9cc3d7f
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_AIOFILES
+       bool "python-aiofiles"
+       depends on BR2_PACKAGE_PYTHON3
+       help
+         aiofiles aims to  handle local disk files in
+         asyncio applications.
+
+         https://pypi.org/project/aiofiles
diff --git a/package/python-aiofiles/python-aiofiles.hash b/package/python-aiofiles/python-aiofiles.hash
new file mode 100644 (file)
index 0000000..3c3e856
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/aiofiles/json
+md5  2243eff06072115e8afe8907677ca51d  aiofiles-0.5.0.tar.gz
+sha256  98e6bcfd1b50f97db4980e182ddd509b7cc35909e903a8fe50d8849e02d815af  aiofiles-0.5.0.tar.gz
+# Locally computed sha256 checksums
+sha256  cb5e8e7e5f4a3988e1063c142c60dc2df75605f4c46515e776e3aca6df976e14  LICENSE
diff --git a/package/python-aiofiles/python-aiofiles.mk b/package/python-aiofiles/python-aiofiles.mk
new file mode 100644 (file)
index 0000000..28f41e3
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-aiofiles
+#
+################################################################################
+
+PYTHON_AIOFILES_VERSION = 0.5.0
+PYTHON_AIOFILES_SOURCE = aiofiles-$(PYTHON_AIOFILES_VERSION).tar.gz
+PYTHON_AIOFILES_SITE = https://files.pythonhosted.org/packages/2b/64/437053d6a4ba3b3eea1044131a25b458489320cb9609e19ac17261e4dc9b
+PYTHON_AIOFILES_SETUP_TYPE = setuptools
+PYTHON_AIOFILES_LICENSE = Apache-2.0
+PYTHON_AIOFILES_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))