speech-tools: fix build failure by using Debian version and patches
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 09:14:00 +0000 (11:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 20:18:56 +0000 (22:18 +0200)
The upstream version of speech-tools does not build with GCC >= 4.3,
mainly due to changes in how C++ headers are included. This is fixed
in Debian, so let's use the Debian version and patches.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/multimedia/festival/speech-tools/speech-tools.mk

index 0aa44ccfae1307e869cee1d16569fe777f3ecdf4..66bd3080bf8397f28615f077009afa86360ab9e2 100644 (file)
@@ -3,9 +3,11 @@
 # speech-tools
 #
 #############################################################
-SPEECH_TOOLS_VERSION = 1.2.96-beta
-SPEECH_TOOLS_SOURCE = speech_tools-$(SPEECH_TOOLS_VERSION).tar.gz
-SPEECH_TOOLS_SITE = http://festvox.org/packed/festival/1.96
+
+SPEECH_TOOLS_VERSION = 1.2.96~beta
+SPEECH_TOOLS_SOURCE = speech-tools_$(SPEECH_TOOLS_VERSION).orig.tar.gz
+SPEECH_TOOLS_PATCH = speech-tools_$(SPEECH_TOOLS_VERSION)-6.diff.gz
+SPEECH_TOOLS_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/s/speech-tools/
 SPEECH_TOOLS_AUTORECONF = NO
 SPEECH_TOOLS_INSTALL_STAGING = NO
 SPEECH_TOOLS_INSTALL_TARGET = YES
@@ -14,6 +16,15 @@ SPEECH_TOOLS_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) STRIP=$(TARGET_STRIP) in
 SPEECH_TOOLS_CONF_OPT =
 SPEECH_TOOLS_MAKE_OPT = CC="$(TARGET_CC)" CXX="$(TARGET_CXX)"
 
+define SPEECH_TOOLS_DEBIAN_PATCH_APPLY
+       # Use the order of the quilt patch series to apply the patches
+       for p in $$(cat $(@D)/debian/patches/series) ; do \
+                toolchain/patch-kernel.sh $(@D) $(@D)/debian/patches $$p; \
+        done
+endef
+
+SPEECH_TOOLS_POST_PATCH_HOOKS += SPEECH_TOOLS_DEBIAN_PATCH_APPLY
+
 SPEECH_TOOLS_DEPENDENCIES = ncurses
 
 $(eval $(call AUTOTARGETS,package/multimedia/festival,speech-tools))