package/gcc: use BR2_USE_WCHAR to set gcc libquadmath option
authorSamuel Martin <s.martin49@gmail.com>
Mon, 27 Jun 2016 15:11:15 +0000 (16:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 15:25:35 +0000 (17:25 +0200)
BR2_TOOLCHAIN_BUILDROOT_WCHAR is only defined when uclibc is selected,
whereas BR2_USE_WCHAR is always defined. Due to this, we were disabling
quadmath support even with glibc or musl.

So, use BR2_USE_WCHAR to drive the gcc libquadmath option.

In addition, invert the logic of the condition to use positive logic,
and rework the comment to no longer mention gcc 4.6: libquadmath still
exists, and it still requires wchar support.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/gcc.mk

index 46f05ff2dbb96922aee8db86e638bbc11e99247e..6e1c02de93422dafe80e2a2953e82f6e36b39b8d 100644 (file)
@@ -106,8 +106,8 @@ ifeq ($(BR2_sparc_v8)$(BR2_sparc_leon3),y)
 HOST_GCC_COMMON_CONF_OPTS += --disable-libitm
 endif
 
-# gcc 4.6.x quadmath requires wchar
-ifneq ($(BR2_TOOLCHAIN_BUILDROOT_WCHAR),y)
+# quadmath support requires wchar
+ifeq ($(BR2_USE_WCHAR),)
 HOST_GCC_COMMON_CONF_OPTS += --disable-libquadmath
 endif