cups: add pdftops option
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 14 May 2009 15:03:23 +0000 (17:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 14 May 2009 15:03:23 +0000 (17:03 +0200)
The pdftops support in cups needs C++ support, whereas the rest doesn't.
Add a BR2_PACKAGE_CUPS_PDFTOPS (depending on C++ support) to enable it
if needed.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cups/Config.in
package/cups/cups.mk

index 8b1f8a5b403ed22f2e9a0f97551388c13c5680be..0176423a161b8a0d27a9c726474dcf3ec213239e 100644 (file)
@@ -4,3 +4,16 @@ config BR2_PACKAGE_CUPS
          The Common Unix Printing System
 
          http://www.cups.org
+
+if BR2_PACKAGE_CUPS
+
+config BR2_PACKAGE_CUPS_PDFTOPS
+       bool "pdftops support"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Enable pdftops support
+
+comment "pdftops support requires a toolchain with C++ support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP
+
+endif
index e3d6f78d15376dc9686f7aac4a3645cbc662696a..d1bf0fa20503eb3d3434c905bd6bd98738157ff5 100644 (file)
@@ -58,6 +58,12 @@ else
        CUPS_CONF_OPT +=        --disable-python
 endif
 
+ifeq ($(BR2_PACKAGE_CUPS_PDFTOPS),y)
+       CUPS_CONF_OPT += --enable-pdftops
+else
+       CUPS_CONF_OPT += --disable-pdftops
+endif
+
 $(DL_DIR)/$(CUPS_SOURCE):
         $(call DOWNLOAD,$(CUPS_SITE),$(CUPS_SOURCE))