uboot-tools: bump to version 2013.07
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 31 Jul 2013 11:06:37 +0000 (08:06 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 Jul 2013 16:00:59 +0000 (18:00 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uboot-tools/uboot-tools-01-drop-configh-from-tools.patch [new file with mode: 0644]
package/uboot-tools/uboot-tools-02-hostcflags-override-fix.patch [new file with mode: 0644]
package/uboot-tools/uboot-tools-drop-configh-from-tools.patch [deleted file]
package/uboot-tools/uboot-tools-hostcflags-override-fix.patch [deleted file]
package/uboot-tools/uboot-tools.mk

diff --git a/package/uboot-tools/uboot-tools-01-drop-configh-from-tools.patch b/package/uboot-tools/uboot-tools-01-drop-configh-from-tools.patch
new file mode 100644 (file)
index 0000000..21995ec
--- /dev/null
@@ -0,0 +1,37 @@
+We need to build u-boot tools without a board configuration for the target.
+fw_env just uses config.h to define the default environment of the created
+image, so it really isn't mandatory.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura u-boot-2013.01.orig/tools/env/fw_env.h u-boot-2013.01/tools/env/fw_env.h
+--- u-boot-2013.01.orig/tools/env/fw_env.h     2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/fw_env.h  2013-01-19 07:58:11.897903403 -0300
+@@ -21,15 +21,6 @@
+  * MA 02111-1307 USA
+  */
+-/* Pull in the current config to define the default environment */
+-#ifndef __ASSEMBLY__
+-#define __ASSEMBLY__ /* get only #defines from config.h */
+-#include <config.h>
+-#undef        __ASSEMBLY__
+-#else
+-#include <config.h>
+-#endif
+-
+ /*
+  * To build the utility with the static configuration
+  * comment out the next line.
+diff -Nura u-boot-2013.01.orig/tools/env/Makefile u-boot-2013.01/tools/env/Makefile
+--- u-boot-2013.01.orig/tools/env/Makefile     2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/Makefile  2013-01-19 07:59:34.926486346 -0300
+@@ -26,7 +26,7 @@
+ HOSTSRCS := $(SRCTREE)/lib/crc32.c  fw_env.c  fw_env_main.c
+ HOSTSRCS += $(SRCTREE)/lib/ctype.c $(SRCTREE)/lib/linux_string.c
+ HOSTSRCS += $(SRCTREE)/common/env_attr.c $(SRCTREE)/common/env_flags.c
+-HEADERS       := fw_env.h $(OBJTREE)/include/config.h
++HEADERS       := fw_env.h
+ # Compile for a hosted environment on the target
+ HOSTCPPFLAGS  = -idirafter $(SRCTREE)/include \
diff --git a/package/uboot-tools/uboot-tools-02-hostcflags-override-fix.patch b/package/uboot-tools/uboot-tools-02-hostcflags-override-fix.patch
new file mode 100644 (file)
index 0000000..0202eda
--- /dev/null
@@ -0,0 +1,29 @@
+[PATCH] Fix tools build with custom HOSTCFLAGS
+
+We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
+overridden on the cmdline.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config.mk |    6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+Index: u-boot-2011.03/config.mk
+===================================================================
+--- u-boot-2011.03.orig/config.mk
++++ u-boot-2011.03/config.mk
+@@ -46,10 +46,12 @@
+ #########################################################################
+-HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+-                $(HOSTCPPFLAGS)
++HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTSTRIP     = strip
++# append CPPFLAGS even if CFLAGS has been overridden on cmdline
++override HOSTCFLAGS += $(HOSTCPPFLAGS)
++
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific.  It
+ # generates numerous errors and warnings.  We want to bypass it
diff --git a/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch b/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch
deleted file mode 100644 (file)
index 21995ec..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-We need to build u-boot tools without a board configuration for the target.
-fw_env just uses config.h to define the default environment of the created
-image, so it really isn't mandatory.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura u-boot-2013.01.orig/tools/env/fw_env.h u-boot-2013.01/tools/env/fw_env.h
---- u-boot-2013.01.orig/tools/env/fw_env.h     2013-01-19 07:50:53.879241660 -0300
-+++ u-boot-2013.01/tools/env/fw_env.h  2013-01-19 07:58:11.897903403 -0300
-@@ -21,15 +21,6 @@
-  * MA 02111-1307 USA
-  */
--/* Pull in the current config to define the default environment */
--#ifndef __ASSEMBLY__
--#define __ASSEMBLY__ /* get only #defines from config.h */
--#include <config.h>
--#undef        __ASSEMBLY__
--#else
--#include <config.h>
--#endif
--
- /*
-  * To build the utility with the static configuration
-  * comment out the next line.
-diff -Nura u-boot-2013.01.orig/tools/env/Makefile u-boot-2013.01/tools/env/Makefile
---- u-boot-2013.01.orig/tools/env/Makefile     2013-01-19 07:50:53.879241660 -0300
-+++ u-boot-2013.01/tools/env/Makefile  2013-01-19 07:59:34.926486346 -0300
-@@ -26,7 +26,7 @@
- HOSTSRCS := $(SRCTREE)/lib/crc32.c  fw_env.c  fw_env_main.c
- HOSTSRCS += $(SRCTREE)/lib/ctype.c $(SRCTREE)/lib/linux_string.c
- HOSTSRCS += $(SRCTREE)/common/env_attr.c $(SRCTREE)/common/env_flags.c
--HEADERS       := fw_env.h $(OBJTREE)/include/config.h
-+HEADERS       := fw_env.h
- # Compile for a hosted environment on the target
- HOSTCPPFLAGS  = -idirafter $(SRCTREE)/include \
diff --git a/package/uboot-tools/uboot-tools-hostcflags-override-fix.patch b/package/uboot-tools/uboot-tools-hostcflags-override-fix.patch
deleted file mode 100644 (file)
index 0202eda..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-[PATCH] Fix tools build with custom HOSTCFLAGS
-
-We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
-overridden on the cmdline.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- config.mk |    6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-Index: u-boot-2011.03/config.mk
-===================================================================
---- u-boot-2011.03.orig/config.mk
-+++ u-boot-2011.03/config.mk
-@@ -46,10 +46,12 @@
- #########################################################################
--HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
--                $(HOSTCPPFLAGS)
-+HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
- HOSTSTRIP     = strip
-+# append CPPFLAGS even if CFLAGS has been overridden on cmdline
-+override HOSTCFLAGS += $(HOSTCPPFLAGS)
-+
- #
- # Mac OS X / Darwin's C preprocessor is Apple specific.  It
- # generates numerous errors and warnings.  We want to bypass it
index ceda3c54601e191ff19765f03b2605ee177e5c30..f8935afcb481a36b3de697bdb36f02aab481abf4 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-UBOOT_TOOLS_VERSION = 2013.04
+UBOOT_TOOLS_VERSION = 2013.07
 UBOOT_TOOLS_SOURCE  = u-boot-$(UBOOT_TOOLS_VERSION).tar.bz2
 UBOOT_TOOLS_SITE    = ftp://ftp.denx.de/pub/u-boot
 UBOOT_TOOLS_LICENSE = GPLv2+