package/gstreamer1/gst1-plugins-bad: add proxy plugin option
authorAdam Duskett <Aduskett@gmail.com>
Thu, 9 May 2019 22:46:21 +0000 (18:46 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 May 2019 19:07:50 +0000 (21:07 +0200)
This plugin was introduced in 1.16.0. It is dependencyless and
provides proxied inter-pipeline communication.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index e0757e96c9216a1125cbf01e7651e1362814057c..c53ff662726e4689d5214b8210a99e82ffa4a8e2 100644 (file)
@@ -212,6 +212,11 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PNM
        help
          PNM plugin
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PROXY
+       bool "proxy"
+       help
+         Proxy plugin
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RAWPARSE
        bool "rawparse"
        help
index a66d3e32bfd04b8cc6b07a7b762c1075a78a9c5d..d6414f9daa8e0de3fa6d7c3f3ab4240700172159 100644 (file)
@@ -344,6 +344,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-pnm
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PROXY),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-proxy
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-proxy
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RAWPARSE),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-rawparse
 else