package/kodi-pvr-stalker: Needs jsoncpp
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 2 Oct 2015 16:31:34 +0000 (18:31 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 Oct 2015 13:19:16 +0000 (15:19 +0200)
Fixes
http://autobuild.buildroot.net/results/56f/56fb98da27495f6a461bfdc7aa8c2de4d86dfdb8/
http://autobuild.buildroot.net/results/f98/f982b437935cf1f921559f5388fd4146eb9241bd/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/kodi-pvr-stalker/Config.in
package/kodi-pvr-stalker/kodi-pvr-stalker.mk

index b327fd879988a4b5aece5f5077d3d22988185848..26a8c3f1a298d8f57e5d2e3eccc6b19cc4e5667f 100644 (file)
@@ -1,7 +1,12 @@
 config BR2_PACKAGE_KODI_PVR_STALKER
        bool "kodi-pvr-stalker"
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # jsoncpp
+       select BR2_PACKAGE_JSONCPP
        select BR2_PACKAGE_KODI_PLATFORM
        help
          A PVR Client that connects Kodi to Stalker Middleware
 
          https://github.com/kodi-pvr/pvr.stalker
+
+comment "kodi-pvr-stalker needs a toolchain w/ gcc >= 4.7"
+       depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
index 589cf7de207729c32e7c2396d4c2622d13bf5606..c1baa8d8014c776901d2620bed60241d4ffa6006 100644 (file)
@@ -8,6 +8,6 @@ KODI_PVR_STALKER_VERSION = 5f6eb1992ffd45a075ebb7bc4253c4a88bf65c80
 KODI_PVR_STALKER_SITE = $(call github,kodi-pvr,pvr.stalker,$(KODI_PVR_STALKER_VERSION))
 KODI_PVR_STALKER_LICENSE = GPLv2+
 KODI_PVR_STALKER_LICENSE_FILES = src/client.h
-KODI_PVR_STALKER_DEPENDENCIES = kodi-platform
+KODI_PVR_STALKER_DEPENDENCIES = jsoncpp kodi-platform
 
 $(eval $(cmake-package))