uclibc-ng-test: pass LDFLAGS while building
authorWaldemar Brodkorb <wbx@openadk.org>
Wed, 22 Feb 2017 18:27:43 +0000 (19:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Feb 2017 20:32:45 +0000 (21:32 +0100)
When static linking is in use we need to pass -static while
linking.

Fixes:
  http://autobuild.buildroot.net/results/37ca35854a36fab1690f6ae789e338a1e55307f6

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc-ng-test/uclibc-ng-test.mk

index 9a0240c431c6ece1a0b832c4db9a2bae417d8c03..610ca010fbf2750c13a99bf29cbd43e257dacfb8 100644 (file)
@@ -39,6 +39,7 @@ define UCLIBC_NG_TEST_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(UCLIBC_NG_TEST_MAKE_ENV) $(MAKE) -C $(@D) \
                CC="$(TARGET_CC)" \
                UCLIBC_EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               UCLIBC_EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
                test_compile
        $(TARGET_MAKE_ENV) $(UCLIBC_NG_TEST_MAKE_ENV) $(MAKE1) -C $(@D) \
                CC="$(TARGET_CC)" \