imx-vpu: remove kernel dependency
authorBaruch Siach <baruch@tkos.co.il>
Wed, 2 Sep 2015 16:54:12 +0000 (19:54 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Oct 2015 19:07:51 +0000 (20:07 +0100)
The imx-vpu package builds just fine without any special kernel header.

Cc: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freescale-imx/imx-vpu/Config.in
package/freescale-imx/imx-vpu/imx-vpu.mk

index 8a9541607bcf4ad2c5a6b9fe9426bf5df8029991..220385cec83d558ba90a3b846e90a2401656c61f 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_IMX_VPU
        bool "imx-vpu"
-       depends on BR2_LINUX_KERNEL
        depends on BR2_arm # Only relevant for i.MX
        select BR2_PACKAGE_FIRMWARE_IMX
        help
@@ -11,7 +10,3 @@ config BR2_PACKAGE_IMX_VPU
 
          This library is provided by Freescale as-is and doesn't have
          an upstream.
-
-comment "imx-vpu needs an imx-specific Linux kernel to be built"
-       depends on BR2_arm
-       depends on !BR2_LINUX_KERNEL
index 4c4a0311144ffc4c1b7b4a272d810ce15a853118..599dce85c945e4f47768ba29fd8d694b905bc1d5 100644 (file)
@@ -10,14 +10,11 @@ IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin
 
 IMX_VPU_INSTALL_STAGING = YES
 
-# imx-vpu needs access to imx-specific kernel headers
-IMX_VPU_DEPENDENCIES += linux
 IMX_VPU_MAKE_ENV = \
        $(TARGET_MAKE_ENV) \
        $(TARGET_CONFIGURE_OPTS) \
        CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
-       PLATFORM=$(BR2_PACKAGE_FREESCALE_IMX_PLATFORM) \
-       INCLUDE="-idirafter $(LINUX_DIR)/include"
+       PLATFORM=$(BR2_PACKAGE_FREESCALE_IMX_PLATFORM)
 
 IMX_VPU_LICENSE = Freescale Semiconductor Software License Agreement
 IMX_VPU_LICENSE_FILES = EULA vpu/EULA.txt