qt: ensure that target dir exists before installing there
authorDanomi Manchego <danomimanchego123@gmail.com>
Tue, 25 Mar 2014 01:05:17 +0000 (21:05 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Mar 2014 21:42:58 +0000 (22:42 +0100)
All of qt.mk's target installs ensure that their destinations exist,
except for /usr/lib.  So do the same for /usr/lib, for consistency,
and in case some combination of custom fs skeleton plus dependency
on Qt leads to installing without a pre-existing /usr/lib directory.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt/qt.mk

index bc329f0bde057437b2df343a84a23083c2d1d815..507e0dbaa20228500db386e1093c3a087d6ae518 100644 (file)
@@ -625,6 +625,7 @@ endef
 # Library installation
 ifeq ($(BR2_PACKAGE_QT_SHARED),y)
 define QT_INSTALL_TARGET_LIBS
+       mkdir -p $(TARGET_DIR)/usr/lib
        for lib in $(QT_INSTALL_LIBS); do \
                cp -dpf $(STAGING_DIR)/usr/lib/lib$${lib}.so.* $(TARGET_DIR)/usr/lib ; \
        done