package/openrc: remove keymaps units if kbd package is not selected
authorCarlos Santos <unixmania@gmail.com>
Sat, 29 Feb 2020 18:26:21 +0000 (15:26 -0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 29 Feb 2020 21:14:50 +0000 (22:14 +0100)
keymaps and save-keymaps require kbd_mode and dumpkeys, respectively, so
remove them if the kbd package is not selected (e.g. devices with serial
console, only).

Signed-off-by: Carlos Santos <unixmania@gmail.com>
Tested-by: Adam Duskett <aduskett@gmail.com>
[yann.morin.1998@free.fr:
  - expand to three commands to match the existing hook
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/openrc/openrc.mk

index 289bde4d03fcc132accd0c9e419eee6da097052b..1f8516f5eec7cef5023bdf29e1af856c171f307e 100644 (file)
@@ -39,6 +39,18 @@ define OPENRC_INSTALL_TARGET_CMDS
                $(TARGET_DIR)/etc/init.d/sysv-rcs
 endef
 
+ifeq ($(BR2_PACKAGE_KBD),)
+# keymaps and save-keymaps require kbd_mode and dumpkeys, respectively, so
+# remove them if the kbd package is not selected (e.g. devices with serial
+# console, only).
+define OPENRC_NO_KBD
+       $(RM) $(TARGET_DIR)/etc/runlevels/boot/{keymaps,save-keymaps}
+       $(RM) $(TARGET_DIR)/etc/init.d/{keymaps,save-keymaps}
+       $(RM) $(TARGET_DIR)/etc/conf.d/keymaps
+endef
+OPENRC_POST_INSTALL_TARGET_HOOKS += OPENRC_NO_KBD
+endif
+
 ifeq ($(BR2_PACKAGE_NETIFRC),y)
 # netifrc replaces network, staticroute and loopback services which are
 # installed by openrc