package: Add sysstat tools
authorLionel Landwerlin <lionel.landwerlin@openwide.fr>
Sun, 18 Oct 2009 19:03:09 +0000 (21:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Oct 2009 21:12:23 +0000 (23:12 +0200)
Signed-off-by: Lionel Landwerlin <lionel.landwerlin@openwide.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/sysstat/Config.in [new file with mode: 0644]
package/sysstat/sysstat.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 29e912db52c9cf616a0d5869559f8434f1eba3d2..20290ddae3f096b03be265875c40ce3497b7004b 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -1,7 +1,7 @@
 2009.11, Not yet released:
 
        New packages: divine, gvfs, libarchive, libmicrohttpd,
-       sdl_sound, swfdec
+       sdl_sound, swfdec, sysstat
 
        Updated/fixed packages: autoconf, busybox, directfb, dnsmasq,
        e2fsprogs, festival, gstreamer, gst-plugins-bad, gst-plugins-base,
index ff7fc3d318436405ca834da386896f547eb2c404..afcfacea8480510447a011106e9850fe8bafefb9 100644 (file)
@@ -270,6 +270,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/sfdisk/Config.in"
 endif
 source "package/smartmontools/Config.in"
+source "package/sysstat/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 # mdev
 source "package/udev/Config.in"
diff --git a/package/sysstat/Config.in b/package/sysstat/Config.in
new file mode 100644 (file)
index 0000000..b084b41
--- /dev/null
@@ -0,0 +1,38 @@
+config BR2_PACKAGE_SYSSTAT
+       bool "sysstat"
+       help
+          The sysstat utilities are a collection of performance
+          monitoring tools for Linux. These include sar, sadf, mpstat,
+          iostat, pidstat and sa tools.
+
+          Some Features :
+
+           * Input / Output and transfer rate statistics (global, per
+             device, per partition, per network filesystem and per
+             Linux task / PID)
+           * CPU statistics (global, per CPU and per Linux task /
+             PID), including support for virtualization architectures
+           * Memory and swap space utilization statistics
+           * Virtual memory, paging and fault statistics
+           * Per-task (per-PID) memory and page fault statistics
+           * Global CPU and page fault statistics for tasks and all
+             their children
+           * Process creation activity
+           * Interrupt statistics (global, per CPU and per interrupt,
+             including potential APIC interrupt sources)
+           * Extensive network statistics: network interface activity
+             (number of packets and kB received and transmitted per
+             second, etc.) including failures from network devices;
+             network traffic statistics for IP, TCP, ICMP and UDP
+             protocols based on SNMPv2 standards; support for
+             IPv6-related protocols.
+           * NFS server and client activity
+           * Socket statistics
+           * Run queue and system load statistics
+           * Kernel internal tables utilization statistics
+           * System and per Linux task switching activity
+           * Swapping statistics
+           * TTY device activity
+           * Power management statistics
+
+         http://pagesperso-orange.fr/sebastien.godard/
diff --git a/package/sysstat/sysstat.mk b/package/sysstat/sysstat.mk
new file mode 100644 (file)
index 0000000..324580e
--- /dev/null
@@ -0,0 +1,26 @@
+#############################################################
+#
+# sysstat
+#
+#############################################################
+
+SYSSTAT_VERSION = 9.0.5
+SYSSTAT_SOURCE = sysstat-$(SYSSTAT_VERSION).tar.bz2
+SYSSTAT_SITE = http://pagesperso-orange.fr/sebastien.godard/
+SYSSTAT_AUTORECONF = NO
+SYSSTAT_LIBTOOL_PATCH = NO
+SYSSTAT_INSTALL_STAGING = NO
+SYSSTAT_INSTALL_TARGET = YES
+
+# Should be --disable-man-group, it might be a little mistake in the
+# configure.in script.
+SYSSTAT_CONF_OPT = --enable-man-group
+ifneq ($(BR2_HAVE_DOCUMENTATION),y)
+SYSSTAT_CONF_OPT += --disable-documentation
+endif
+
+# The isag tool is a post processing script that depends on tcl/tk
+# among other things. So we don't install it.
+SYSSTAT_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) INSTALL_ISAG=n install
+
+$(eval $(call AUTOTARGETS,package,sysstat))